Jump to content


Photo

[Linux] How to reset resolution

linux resolution settings

  • Please log in to reply
9 replies to this topic

#1 Nienna

Nienna

    Rubber Ducky

  • Minstrum
  • Pip
  • 5 posts
  • LocationBergen, Norway

Posted 22 October 2014 - 07:11

Hi guys! I finally got the out of memory crash error fixed, and now I've got another issue: My dual monitor setup has tricked the game into starting in 3840x1080, and I can only see half the screen setup. For some reason I can't get into the visuals setup screen (the button apparently does nothing), so I have no way of resetting this. I've tried deleting and reinstalling the game from Steam, but the settings didn't reset to default.

 

Any ideas?



#2 Nienna

Nienna

    Rubber Ducky

  • Minstrum
  • Pip
  • 5 posts
  • LocationBergen, Norway

Posted 22 October 2014 - 11:48

Nobody? Red Thread? I guess you're getting some much needed and much deserved sleep, but once you're awake?

#3 Morten

Morten

    RTG Programmer

  • RTG Staff
  • 1058 posts
  • LocationOslo, Norway

Posted 22 October 2014 - 13:05

You could try deleting the saved preferences for the game in the registry.

On Linux this can be found at: "~/.config/unity3d/Red Thread Games/Dreamfall Chapters"

 

However, the game's resolution will default to the native resolution of your system. So you can maybe try to set the native resolution before opening the game the first time after deleting the registry folder. :)

Hope this helps.


Red Thread Games PR0grammer & Naturally Selected Part-Time "Keep Track of Forum"-person / Community Overseer


#4 enykeev

enykeev

    Rubber Ducky

  • Member
  • Pip
  • 3 posts

Posted 22 October 2014 - 13:14

You could try deleting the saved preferences for the game in the registry.

On Linux this can be found at: "~/.config/unity3d/Red Thread Games/Dreamfall Chapters"

 

However, the game's resolution will default to the native resolution of your system. So you can maybe try to set the native resolution before opening the game the first time after deleting the registry folder. :)

Hope this helps.

 

Where do I find this folder on a mac? Can't find it neither in ~/.config nor in ~/Library/Application Support.

 

UPD. Found it. ~/Library/Preferences/unity.Red\ Thread\ Games.Dreamfall\ Chapters.plist



#5 Morten

Morten

    RTG Programmer

  • RTG Staff
  • 1058 posts
  • LocationOslo, Norway

Posted 22 October 2014 - 13:24

Here are the folders for the saved preferences for each platform:

Windows: Open regedit.exe to view the registry files, then go to "HKCU\Software\Red Thread Games\Dreamfall Chapters"

Mac: "~/Library/Preferences" in a file named "unity.Red Thread Games.Dreamfall Chapters.plist"

Linux: "~/.config/unity3d/Red Thread Games/Dreamfall Chapters"

 

Hope this helps people with similar issues.


Red Thread Games PR0grammer & Naturally Selected Part-Time "Keep Track of Forum"-person / Community Overseer


#6 Nienna

Nienna

    Rubber Ducky

  • Minstrum
  • Pip
  • 5 posts
  • LocationBergen, Norway

Posted 22 October 2014 - 14:04

Thanks Morten, finding and editing the prefs file helped a lot!

 

 



#7 Andreo

Andreo

    Rubber Ducky

  • Istrum
  • Pip
  • 2 posts

Posted 22 October 2014 - 14:33

Is any option how to change visual settings to lowest except game's menu? Example config file. Default is set High. After to change resolution to 800x600 (via config file) is still performance very bad and game's menu very slow response. My PC configuration is: Mint 17(based Ubuntu 14.04), Intel Core 2 Duo 2.2GHz, 4GB RAM, NV GF9300M GS 512 VRAM. I hope it is minimal requirements. Sorry for my english.



#8 khh

khh

    Harbinger of the Balance

  • Moderator
  • 7098 posts
  • LocationNorway

Posted 22 October 2014 - 14:38

Is any option how to change visual settings to lowest except game's menu? Example config file. Default is set High. After to change resolution to 800x600 (via config file) is still performance very bad and game's menu very slow response. My PC configuration is: Mint 17(based Ubuntu 14.04), Intel Core 2 Duo 2.2GHz, 4GB RAM, NV GF9300M GS 512 VRAM. I hope it is minimal requirements. Sorry for my english.

You are above the minimum requirements.

 

I don't know of any other (easy) way to set the options, rather than the menu. The config file should be in this directory

Linux: "~/.config/unity3d/Red Thread Games/Dreamfall Chapters"

But I don't know how easy it is to change the settings manually. 


April Ryan is my friend,
Every sorrow she can mend.
When I visit her dark realm,
Does it simply overwhelm.


#9 km3k

km3k

    Rubber Ducky

  • Vestrum
  • Pip
  • 7 posts

Posted 22 October 2014 - 16:02

This didn't work for me. For some reason the game didn't put the Unity config in "~/.config/unity3d/Red Thread Games/Dreamfall Chapters" for me upon first run of the game, so I found another way. It appears that some later run of the game did put the file there correctly though.

 

If using Steam, an alternative is to use the following launch options:

-popupwindow -screen-width 1920

where you replace 1920 with the resolution width of one of your monitors

 

You could probably add this to the end of the command to launch the game if using the DRM-free version too.



#10 Andreo

Andreo

    Rubber Ducky

  • Istrum
  • Pip
  • 2 posts

Posted 22 October 2014 - 17:20

You are above the minimum requirements.
 
I don't know of any other (easy) way to set the options, rather than the menu. The casingonfig file should be in this directory
Linux: "~/.config/unity3d/Red Thread Games/Dreamfall Chapters"
But I don't know how easy it is to change the settings manually.

Thank you for your answer. I set visual settings to Low via game's menu, but I had to be very patient. Performance no change:( . I try Windows version. Visual setting can also be changed via config file (Linux: "~/.config/unity3d/Red Thread Games/Dreamfall Chapters/prefs")

Example:
Visual Quality: Low
Resolution: 800x600
FullScreen: on
Anti-Aliasing: none
SSAO: off
 
For set via config file add/change these lines to file:
 

<pref name="UnityGraphicsQuality" type="int">0</pref>
<pref name="Screenmanager Resolution Height" type="int">600</pref>
<pref name="Screenmanager Resolution Width" type="int">800</pref>
<pref name="Screenmanager Is Fullscreen mode" type="int">1</pref>
<pref name="AntiAliasing" type="int">0</pref>
<pref name="SSAO" type="int">0</pref>

Maybe help someone.

 


  • Morten and khh like this





Also tagged with one or more of these keywords: linux, resolution, settings

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users