Jump to content


Photo

DFC Performance on Windows 10


  • Please log in to reply
5 replies to this topic

#1 kamikaze

kamikaze

    Rubber Ducky

  • Forum Beta Tester
  • Pip
  • 22 posts
  • Location/Earth/Europe/Germany/Karlsruhe

Posted 10 June 2018 - 13:42

This week my copy of the game finally arrived so I finally wanted to start playing it (it's been a while since the kickstarter). I'm running it on Windows 10 with a GTX 760, which is usually decent enough for most games at Full HD.

 

Unfortunately the game is completely unplayable, picture and sound stutter like crazy. From @2160p/awesome down to @1080p/low the performance is exactly the same.

 

Turning G-Sync off didn't help either (that's what does the trick for some old games like Starcraft 1).

 

I switched from balanced to high performance just to make sure. But obviously that wasn't it either (this seems to be a common recommendation here, it sounds very far fetched to me, there's no reason not to utilise 100% of a CPU core even on a battery driven system, the task would just take longer and consume at least as much power).

 

I guess I can provide the dxdiag and log stuff. But is there anything obvious left to do first?


[ FreeBSD ports - XC878 libraries - kamikaze@bsdforen.de ]
----
Unicycling, dancing, FreeBSD, embedded C/electronics, FSAE, ponies, Heavy/Thrash/Death Metal and a hacker, that's me in a nutshell.


#2 kamikaze

kamikaze

    Rubber Ducky

  • Forum Beta Tester
  • Pip
  • 22 posts
  • Location/Earth/Europe/Germany/Karlsruhe

Posted 10 June 2018 - 16:32

Just a little heads up, I went down to @720p, set everything to as low as possible. There is no difference in performance to @4k/awesome.


[ FreeBSD ports - XC878 libraries - kamikaze@bsdforen.de ]
----
Unicycling, dancing, FreeBSD, embedded C/electronics, FSAE, ponies, Heavy/Thrash/Death Metal and a hacker, that's me in a nutshell.


#3 kamikaze

kamikaze

    Rubber Ducky

  • Forum Beta Tester
  • Pip
  • 22 posts
  • Location/Earth/Europe/Germany/Karlsruhe

Posted 10 June 2018 - 18:14

Another heads up, I tested with the "the story so far". Turns out playing the actual game I don't have any issues.


[ FreeBSD ports - XC878 libraries - kamikaze@bsdforen.de ]
----
Unicycling, dancing, FreeBSD, embedded C/electronics, FSAE, ponies, Heavy/Thrash/Death Metal and a hacker, that's me in a nutshell.


#4 Indrid Cold

Indrid Cold

    Harbinger of the Balance

  • Vestrum
  • PipPipPipPipPipPip
  • 3076 posts

Posted 11 June 2018 - 01:05

It's been a while since I last played, but unless I'm mistaken "the story so far" is just a pre-rendered video, correct?

I remember people in the past having trouble with the game intro which was also pre-rendered. I can't remember if that still exists in the latest version.

#5 Mr Moo

Mr Moo

    Harbinger of the Balance

  • Vestrum
  • PipPipPipPipPipPip
  • 2082 posts
  • LocationNorway

Posted 11 June 2018 - 17:28

There is a known problem with the pre-rendered videos on some computers, but only two videos are pre-rendered, as far as I know. The game itself should work as long as your computer isn't ancient.

 

The videos don't work on some computers, for reasons the developers are unaware of. Probably some bug in the engine which will never be fixed.

 

There are links to youtube versions of the non-working videos in this thread:

https://forum.redthr...efore-starting/



#6 kamikaze

kamikaze

    Rubber Ducky

  • Forum Beta Tester
  • Pip
  • 22 posts
  • Location/Earth/Europe/Germany/Karlsruhe

Posted 11 June 2018 - 18:14

Thanks for the responses, I didn't notice it's a video!

 

Windows 10 generally seems to have problems with video. At least 4k@60hz video is a really crappy experience, while booting FreeBSD everything is just fine, even in browser.


[ FreeBSD ports - XC878 libraries - kamikaze@bsdforen.de ]
----
Unicycling, dancing, FreeBSD, embedded C/electronics, FSAE, ponies, Heavy/Thrash/Death Metal and a hacker, that's me in a nutshell.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users