Jump to content


Photo

Crash during Book Four

crash Book Four loading screen

  • Please log in to reply
4 replies to this topic

#1 Nanoloque

Nanoloque

    Fringe Café Regular

  • Vestrum
  • PipPip
  • 106 posts
  • LocationFrance

Posted 16 November 2017 - 17:47

Looks like I won't get through the end of the saga. :( My game has known many crashes until now but one really prevents me from finishing it.

 

The crash occurs in Book Four: Revelations, Chapter Nine: Journeys, in Marcuria by daylight. There is a loading screen after Crow introduces Zoë to its "cunning plan" ("Oh oh" is right, Zoë). The loading screen never ends, there is a crash before the cutscene.

 

I tried loading two different saves, disabling the subtitles, changing the graphics settings, switching to windows display... Still the same result.

 

I run the Steam version of Dreamfall Chapters (Final Cut installed) on Windows 7 and I have attached the output log.

 

What should I do? Please let me discover the cunning plan of Crow! :'(

Attached File  output_log.txt   23.83KB   4 downloads


  • Victorplepe likes this

#2 Morten

Morten

    RTG Programmer

  • RTG Staff
  • 1057 posts
  • LocationOslo, Norway

Posted 20 November 2017 - 15:25

Thank you for your report. We are currently investigating this issue internally.


Red Thread Games PR0grammer & Naturally Selected Part-Time "Keep Track of Forum"-person / Community Overseer


#3 briarrose

briarrose

    Rubber Ducky

  • RTG Staff
  • 5 posts

Posted 21 November 2017 - 10:41

Hi Nanoloque! 

 

There have been quite a number of reports of crashes and freezes where the issue was a failure to run DirectX 11 on older graphics hardware (which seems to be a common problem with Unity games). The last line in your output_log suggests the same problem (d3d11: failed to create vertex buffer of size 96 [0x887A0005]).

 

Try forcing DirectX 9, and if that gets you past you can switch back to DX11 or continue playing with DX9 (which should prove more stable). The instructions can be found in this post:

 

https://forum.redthr...ashes/?p=150313

 

Hope it helps!



#4 Nanoloque

Nanoloque

    Fringe Café Regular

  • Vestrum
  • PipPip
  • 106 posts
  • LocationFrance

Posted 23 November 2017 - 12:14

Thank you! I followed your instructions: by forcing DirectX 9 until the end of the game, I didn't have anymore crashes. A pity, though: I did buy my graphics hardware to run DX11 games.

 

You can lock this topic if you want.


  • khh likes this

#5 Mr Moo

Mr Moo

    Harbinger of the Balance

  • Vestrum
  • PipPipPipPipPipPip
  • 2052 posts
  • LocationNorway

Posted 04 December 2017 - 18:42

AMD Radeon HD 6870 (as claimed by your log) was launched October 22, 2010. That's more than 7 years ago and in computer terms known as ancient times.







Also tagged with one or more of these keywords: crash, Book Four, loading screen

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users