Jump to content


Photo

Flickering Textures in Dreamfall / Windows 7 / Intel HD Graphics 530


  • Please log in to reply
12 replies to this topic

#1 Journeyperson

Journeyperson

    Rubber Ducky

  • Member
  • Pip
  • 5 posts

Posted 26 March 2016 - 11:46

Hello all.

 

I just installed Dreamfall: The Longest Journey on my new PC, which came with an Intel Core i5 Skylake CPU. Dreamfall starts up all right but is next to unplayable because of strange graphics glitches. See the attached screenshot. Many of the textures flicker constantly as long as the camera is moving. When I let go of the mouse and the camera eventually stops moving, the flickering stops as well.

 

Is there any cure for this? My OS is Windows 7 64-bit. I have the latest Intel graphics driver version (currently 20.19.15.4352). My copy of Dreamfall is the original DVD version. I've tried the lowest graphics and effect quality settings inside the game, as well as turning anti-aliasing off, and nothing has worked.

 

I would appreciate any assistance.

Attached Files



#2 khh

khh

    Harbinger of the Balance

  • Moderator
  • 7061 posts
  • LocationNorway

Posted 28 March 2016 - 10:33

I've never seen an issue like this before. Sorry.

 

Some googling suggests that this might be related to Anti Aliasing. Does it still happen if you turn that off?


  • agirlnamedbob likes this

April Ryan is my friend,
Every sorrow she can mend.
When I visit her dark realm,
Does it simply overwhelm.


#3 Journeyperson

Journeyperson

    Rubber Ducky

  • Member
  • Pip
  • 5 posts

Posted 28 March 2016 - 13:42

Turning anti-aliasing off inside Dreamfall has no effect and neither does doing the same in the Intel HD Graphics control panel. The control panel, disappointingly, provides a very small number of configuration options.

 

One thing I'd like to clarify is that in the cutscene where the screenshot was taken, the entire landscape is filled with those black patches which blink on and off, from one frame to the next.

 

I'm no expert, but I think this problem could be related to bump maps. The landscape is covered with snow and ice that has a rough bumpy surface. Also, the very first moment in the game where the glitch is visible is in the ritual chamber right before this cutscene. There are metallic surfaces everywhere in the room and they blink irritatingly. I think they are bump-mapped. Every flat, non-bumpy texture seems to work without issues.

 

Is there any way to completely disable bump maps in Dreamfall, so I could test this?



#4 Dreamcatcher

Dreamcatcher

    Arcadia Native

  • Vestrum
  • PipPipPip
  • 146 posts
  • LocationGermany

Posted 28 March 2016 - 16:08

Is there any way to completely disable bump maps in Dreamfall, so I could test this?

There is no way to turn it off.

I think it is unlikely that bumpmaps are the cause of this.

 because lots of textures have a bumpmap (if not almost all),
even if it is hardly visible,
The brick walls in westinghouses cell in the beginning for example.

I really do not have a solid Idea what could cause this,

 

maybe it is an issue with the graphics driver (you could try a different version)
Or it is caused by the shared system Ram used by the graphics card. It should be around 1.7GB.
That is what I found mentioned as a default, but maybe your system can not free up enough Ram for the internal Card,
or you have some system settings in place that limits the amount of Ram used by the card.
(unlikely, because everything should be handled automatically and be fine, and the Game should not need much)

You could try to download and play a trial version of the Game at the Homepage http://www.dreamfall.com and see if the Problem
is still there. If it is gone, it is your Version of the Game that produces this error,
and if it is, then it is something in your System configuration.

You could also try to run it in WinXP compatibility mode.
And just to try everything possible in windowed Mode as described here:
http://pcgamingwiki....Longest_Journey

 

I have doubts any of this will solve it, maybe the best bet is a different version of the Graphics driver.
 


  • agirlnamedbob and khh like this

#5 agirlnamedbob

agirlnamedbob

    Harbinger of the Balance

  • Moderator
  • 11158 posts
  • LocationWisconsin, USA

Posted 28 March 2016 - 16:10

I'm also not sure whether or not you're on Steam, but if so I almost always recommend trying to verify your game cache, assuming you haven't already. I'm not sure that's the culprit in this case, but we've had a fair number of weird glitches that were caused by a random corrupted file. 


Erika - Friendly RTG Moderator

Facebook - Twitter - Steam - Twitch


#6 Lee-m

Lee-m

    Harbinger of the Balance

  • Vestrum
  • PipPipPipPipPipPip
  • 1789 posts
  • LocationYorkshire, England

Posted 28 March 2016 - 16:41

I'm also not sure whether or not you're on Steam..

The OP clearly states it is the original DVD version. Which would mean they had to fix the starforce issue first just to get the game to run ?

Anyway the Intel HD chipset wasnt even around at the time of the original Dreamfall release, so if it works, fine. But if it doesnt work on your revision of the HD chipset, then you are largely out of luck.
Try a dedicated nvidia card, and i'm sure it will work fine. At the end of the day, the game is 10 years old now.

#7 agirlnamedbob

agirlnamedbob

    Harbinger of the Balance

  • Moderator
  • 11158 posts
  • LocationWisconsin, USA

Posted 28 March 2016 - 16:49

The OP clearly states it is the original DVD version. Which would mean they had to fix the starforce issue first just to get the game to run ?

 

Missed that. That's what I get for reading fast. So similar advice would be to try reinstalling, just to be sure. I had a helluva time trying to get the game installed off of my old DVD without errors. I think I finally just gave up and bought it again off of GOG or Steam. 

 

 

I know I've had the game running on an Intel HD chipset without issue, but it was a different chipset, so yeah. :/ Could just be that, then. 


Erika - Friendly RTG Moderator

Facebook - Twitter - Steam - Twitch


#8 Journeyperson

Journeyperson

    Rubber Ducky

  • Member
  • Pip
  • 5 posts

Posted 28 March 2016 - 19:02

Thanks for all the responses and suggestions.

 

lots of textures have a bumpmap (if not almost all)

 

You are right. I see there are bump maps everywhere, now that I look closely. The problem only seems to concern bumpy surfaces that reflect light in a specific way. I'm afraid I'm not familiar with the terminology.

 

I tried both WinXP compatibility mode and windowed mode, but they didn't help. I don't really feel like downloading the 3.47 GB trial version. I guess it is one of the last straws to try. If I do download it, will Windows allow me to run it while the full game is already installed?

 

My system has 8 GB of RAM, and if I'm reading the findings of "dxdiag" correctly, the shared display memory is 1632 MB, i.e. along the lines of what you said.

 

Try a dedicated nvidia card, and i'm sure it will work fine. At the end of the day, the game is 10 years old now.

 

I agree the problem is most probably caused by the new graphics hardware being incompatible with the old game, or the other way around. I haven't yet tried running other games from that time period with this setup, but I might just have to start looking for a dedicated card.



#9 Journeyperson

Journeyperson

    Rubber Ducky

  • Member
  • Pip
  • 5 posts

Posted 03 April 2016 - 21:22

Well, the good news is that I've found a workaround. I've got Windows XP running in VirtualBox and Dreamfall works fine inside that. It's not as fast as I'd like it to be, but at least it's playable and there are no glitches.


  • khh and Dreamcatcher like this

#10 Dreamcatcher

Dreamcatcher

    Arcadia Native

  • Vestrum
  • PipPipPip
  • 146 posts
  • LocationGermany

Posted 04 April 2016 - 12:25

Using hardware that can´t run the game to emulate hardware that can.

That is a creative solution. :lol: B)

Did you intall the guest additions and enable 3d acceleration?
You probably did, but if not:
https://www.virtualb...#guestadd-video
a step by step tutorial on youtube:



#11 Journeyperson

Journeyperson

    Rubber Ducky

  • Member
  • Pip
  • 5 posts

Posted 05 April 2016 - 18:10

Using hardware that can´t run the game to emulate hardware that can.

That is a creative solution. :lol: B)

 

I thought so too!

 

I have indeed enabled 3D acceleration according to the instructions. I don't think I would've been able to launch Dreamfall at all without it.

 

Thanks for your help, everyone!



#12 Indrid Cold

Indrid Cold

    Harbinger of the Balance

  • Vestrum
  • PipPipPipPipPipPip
  • 3043 posts

Posted 05 April 2016 - 18:22

I wouldn't have thought Virtualbox's emulated graphics card was good enough to run Dreamfall! Wow.



#13 RêvesRadioactifs

RêvesRadioactifs

    Rubber Ducky

  • Member
  • Pip
  • 1 posts

Posted 10 July 2016 - 16:47

A bit late, I know, but I'm having the same issue on a Skylake i7 GPU. I'll purchase a proper, dedicated GPU soon, though, so that should hopefully fix it.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users