Jump to content


Photo

Ubuntu can't start book 4

ubuntu

  • Please log in to reply
6 replies to this topic

#1 alienflorina

alienflorina

    Rubber Ducky

  • Member
  • Pip
  • 3 posts

Posted 04 December 2015 - 14:36

I've just downloaded book4 and for some reason the game doens't respond at the titles menu. After I press space I don't get anything. The music and animation still playing, so its not a freeze. 

 

Unfortunately I have no clue if the other books were working on ubuntu because I used to play on windows. Unfortunately I'm travelling right now and would like to play on my laptop.

 

I'm running Ubuntu 15.10 on an i5 5200U with HD 5500 which is more than enough to run the game according to specs. 

 

DOes anyone have same issues?



#2 DiskJunky

DiskJunky

    Harbinger of the Balance

  • Drachkin
  • PipPipPipPipPipPip
  • 3091 posts
  • LocationBehind you (mwuh ha ha!)

Posted 04 December 2015 - 15:53

I've just downloaded book4 and for some reason the game doens't respond at the titles menu. After I press space I don't get anything. The music and animation still playing, so its not a freeze. 

 

Unfortunately I have no clue if the other books were working on ubuntu because I used to play on windows. Unfortunately I'm travelling right now and would like to play on my laptop.

 

I'm running Ubuntu 15.10 on an i5 5200U with HD 5500 which is more than enough to run the game according to specs. 

 

DOes anyone have same issues?

Just ruling it out but... what controller settings are set? I know it's unlikely you have an actual controller attached if it's a laptop but maybe it defaulted to those settings? Alternatively, the game might not have focus. Have you tried alt+tabbing back to the desktop and back to the game again?


  • khh likes this

Knowledge is knowing a tomato is a fruit. Wisdom is not putting it in a fruit salad.


#3 alienflorina

alienflorina

    Rubber Ducky

  • Member
  • Pip
  • 3 posts

Posted 04 December 2015 - 18:42

Just ruling it out but... what controller settings are set? I know it's unlikely you have an actual controller attached if it's a laptop but maybe it defaulted to those settings? Alternatively, the game might not have focus. Have you tried alt+tabbing back to the desktop and back to the game again?

Well thanks for the answer. No I haven't a controler, but how do i change those settings? Alt-tab does not do anything



#4 alienflorina

alienflorina

    Rubber Ducky

  • Member
  • Pip
  • 3 posts

Posted 04 December 2015 - 18:43

Well thanks for the answer. No I haven't a controler, but how do i change those settings? Alt-tab does not do anything

Also the mouse is not moving



#5 slektstreff

slektstreff

    Rubber Ducky

  • Member
  • Pip
  • 10 posts

Posted 04 December 2015 - 20:19

Similar problem on Ubuntu 14.04. I can start the game, but only after waiting for a very long time for the menu animations - which seem to have become an extremely tough job for my computer to animate - to lag by while I choose to either load or start a new game. My saves in the Enclave/Resistance HQ and other small spaces are playable (although way laggier than they used to be), but larger spaces are hopeless (about 1/2 frame per second).

 

I've sent a bug report, but I can imagine this bug being a pain to track unless they have a computer with similar specs and Ubuntu installed to test on. Please let me know if there's any info not included in the report that I can provide here.

 

Btw, the mouse pointer is moving without lag in my case. Waiting for the "press space or (A)" text to fade into the main menu takes up to 10 seconds, though, and I have to press space multiple times for the game to even recognise it.


  • alienflorina likes this

#6 Morten

Morten

    RTG Programmer

  • RTG Staff
  • 1058 posts
  • LocationOslo, Norway

Posted 05 December 2015 - 00:54

Similar problem on Ubuntu 14.04. I can start the game, but only after waiting for a very long time for the menu animations - which seem to have become an extremely tough job for my computer to animate - to lag by while I choose to either load or start a new game. My saves in the Enclave/Resistance HQ and other small spaces are playable (although way laggier than they used to be), but larger spaces are hopeless (about 1/2 frame per second).

 

I've sent a bug report, but I can imagine this bug being a pain to track unless they have a computer with similar specs and Ubuntu installed to test on. Please let me know if there's any info not included in the report that I can provide here.

 

Btw, the mouse pointer is moving without lag in my case. Waiting for the "press space or (A)" text to fade into the main menu takes up to 10 seconds, though, and I have to press space multiple times for the game to even recognise it.

Are you sure you are running the correct graphics driver?
If you haven't selected another driver since you installed Ubuntu, then it's probably using the Nouveau driver that's being used by default.

If that's the case, try changing to the latest available driver for your graphics device.


Red Thread Games PR0grammer & Naturally Selected Part-Time "Keep Track of Forum"-person / Community Overseer


#7 slektstreff

slektstreff

    Rubber Ducky

  • Member
  • Pip
  • 10 posts

Posted 05 December 2015 - 17:52

I'm on Intel Haswell, so no Noveau.

 

I know Haswell is a rather low-end (pseudo-)GPU to use for a proper 3D game like Chapters, but it used to run perfectly well until the Chapter 4 / Unity 5 update came out. I could set it to up to medium "visual quality" and use low anti-aliasing at 1900xsomething pixels without the game feeling slow at all.

 

Tried updating to the latest official lts-kernel packages today (currently at 4.2.0-19-generic) to see if it would make any difference. The menu actually lags a little bit less now (granted, it's still pretty laggy), but all gameplay is still practically the same as with previous kernels (3.19.x).







Also tagged with one or more of these keywords: ubuntu

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users