Jump to content


Photo

(Book 4) game freezes constantly in Marcuria

Unity 5

  • Please log in to reply
10 replies to this topic

#1 Sméagol

Sméagol

    Rubber Ducky

  • Vestrum
  • Pip
  • 42 posts
  • LocationSchiedam, The Netherlands

Posted 03 December 2015 - 20:42

So yeah, the engine update doesn't seem like an improvement for me.

 

The rebel base is fine, but when I enter Marcuria, the game freezes regularly, albeit at random moments. Sometimes later, sometimes earlier. It makes my whole system freeze. It looks like a graphics issue, but setting the graphics to low doesn't help. My hardware hasn't changed, and I never had such problems before the engine update.. This is frustrating.

 

I'm using an AMD R7 260, Intel core I7, and 12 GB ram. OS is Windows 7 (64 bit).

 

Edit:

I forgot the most obvious thing to update the drivers.. Stand by.

 

Edit:

Doesn't seem to help either.

 

Edit:

Giving up, this is unplayable.

Attached Files



#2 khh

khh

    Harbinger of the Balance

  • Moderator
  • 7118 posts
  • LocationNorway

Posted 03 December 2015 - 23:29

Hmm... deckarde reported a similar problem in the salty seaman (quoted below). I'll ask him about what card he has, maybe there's a related issue here?

 

I'll also move this thread to the General Support forum.

 

Is there any way to check how your graphics card is feeling? Because, DFC just froze for me, like it did with Witcher 3 and I thought that W3 did it because it took a large toll on my graphics card. But maybe it did something worse to it.


April Ryan is my friend,
Every sorrow she can mend.
When I visit her dark realm,
Does it simply overwhelm.


#3 Sméagol

Sméagol

    Rubber Ducky

  • Vestrum
  • Pip
  • 42 posts
  • LocationSchiedam, The Netherlands

Posted 03 December 2015 - 23:46

Well, I doubt it's an actual performance issue, as I've tried setting everything to low, including the resolution, and it still froze. Screen becomes black, system doesn't respond anymore. And like I said, it only happened in Marcuria, the first segment inside the base is perfectly fine. So there's something in Marcuria that has changed with the engine update, that my system doesn't like.



#4 rgochnour

rgochnour

    Fringe Café Regular

  • Member
  • PipPip
  • 90 posts
  • LocationOregon, USA

Posted 04 December 2015 - 07:47

I just had the same thing happen, or something similar.

I was just starting the new book and was still in the enclave when the screen went "crazy" before turning totally black and the entire system was dead.

My system in Win 7, 64 bit

AMD FX-6300, 16G RAM.

Radeon R7 200 series, 2G memory

 

Update - restarted the game, after restarting the pc, and I did not get the crash in the same place and have been able to move on into the city without any problems


  • khh likes this

#5 khh

khh

    Harbinger of the Balance

  • Moderator
  • 7118 posts
  • LocationNorway

Posted 04 December 2015 - 09:43

Well, I doubt it's an actual performance issue, as I've tried setting everything to low, including the resolution, and it still froze. Screen becomes black, system doesn't respond anymore. And like I said, it only happened in Marcuria, the first segment inside the base is perfectly fine. So there's something in Marcuria that has changed with the engine update, that my system doesn't like.

I think there is a problem in the game where the V-sync option doesn't work on some AMD cards. If your card is rendering as hard as it can constantly, there is the chance that it could overheat. I've had that happen to me with HIS' AMD cards before. And if that is the case, then turning down the graphics settings wouldn't make a difference.

Could you maybe try enabling the frame limiter in the driver software itself (cap at 60 fps) and see if that makes a difference? It might not, but it wouldn't hurt to try.


April Ryan is my friend,
Every sorrow she can mend.
When I visit her dark realm,
Does it simply overwhelm.


#6 Morten

Morten

    RTG Programmer

  • RTG Staff
  • 1059 posts
  • LocationOslo, Norway

Posted 04 December 2015 - 10:22

Hmm yeah. If you've got V-Sync enable and your GPU is running haywire, that means there's something blocking it from working.

The V-Sync feature we're using is built into the Unity engine and should work normally, but I'll see if this may be a hardware specific issue as well, as I see you both are using AMD R7s.


Red Thread Games PR0grammer & Naturally Selected Part-Time "Keep Track of Forum"-person / Community Overseer


#7 Sméagol

Sméagol

    Rubber Ducky

  • Vestrum
  • Pip
  • 42 posts
  • LocationSchiedam, The Netherlands

Posted 11 December 2015 - 21:21

I thought I posted in this, but something went wrong apparently. Anyway, update:

 

This has nothing to do with the load on the graphics card. I turned everything off, and set the resolution to the lowest available. I still have the same problem. There's something in the new engine that doesn't agree with my system, perhaps some incompatible shader or something. I don't have any problems with my fans or temperature in general.

 

I also loaded an earlier chapter from book 3, chapter 8 I believe, I was running around with Zoë, and eventually, I got the same problem. I've played this chapter (and everything else before book 4) without any major problems, but now with the update, the game is unplayable.

 

Looks like this engine could use some more optimisation.. When is a patch coming?



#8 Ikon

Ikon

    Harbinger of the Balance

  • Istrum
  • PipPipPipPipPipPip
  • 2788 posts

Posted 11 December 2015 - 21:56

Wouldn't an engine patch have to come from Unity? If so, how would RTG know when one is coming?


If at first you don't succeed, do it like your mother told you.


#9 Morten

Morten

    RTG Programmer

  • RTG Staff
  • 1059 posts
  • LocationOslo, Norway

Posted 14 December 2015 - 11:23

I'm sorry that you are having this issue, but as of now there's nothing we can do about this. It's most likely something with your hardware not playing nice with the rendering pipeline of Unity.

 

However, I just wanted to ask if you've checked your AMD control panel and made sure you are not overriding some specific rendering settings. Maybe if you have something like V-Sync/G-sync forced off and that overrides the behavior of the in-game setting, that could maybe explain your graphics card overheating and shutting down your computer.


Red Thread Games PR0grammer & Naturally Selected Part-Time "Keep Track of Forum"-person / Community Overseer


#10 Sméagol

Sméagol

    Rubber Ducky

  • Vestrum
  • Pip
  • 42 posts
  • LocationSchiedam, The Netherlands

Posted 15 December 2015 - 14:26

My card isn't overheating. V-sync is currently turned off both in-game as in the AMD settings.



#11 Morten

Morten

    RTG Programmer

  • RTG Staff
  • 1059 posts
  • LocationOslo, Norway

Posted 15 December 2015 - 16:46

Oh, sorry. I must have overlooked the post where you stated there wasn't a temperature problem.

It could be, as you mentioned, that a certain asset or whatever is not playing nice with your hardware, but I would highly doubt it. However, something's causing trouble for you, but I don't know what.

 

The log you've attached in your first post doesn't indicate anything out of the ordinary. Again, I'm sorry that you're having trouble with this, but it's really hard to say anything about what is happening at this point.  :blink:


Red Thread Games PR0grammer & Naturally Selected Part-Time "Keep Track of Forum"-person / Community Overseer






Also tagged with one or more of these keywords: Unity 5

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users