Jump to content


Photo

No Triplebuffering in 3.2.0 Beta


  • Please log in to reply
11 replies to this topic

#1 Bloodshed

Bloodshed

    Rubber Ducky

  • Istrum
  • Pip
  • 5 posts
  • LocationAustria

Posted 30 October 2015 - 22:57

Gave the beta a quick testrun, performance is way up compared to Unity 4, but as soon as the framerate drops below 60 (vsync), fps drop to 30 instantly, meaning the engine doesn't use triplebuffering, so one can only choose between massive tearing or fps jumps from vsync to vsync/2 and back again, which in turn renders the improved performance pretty much useless.

Hope this will be activated in subsequent builds.

 


  • Vainamoinen and khh like this

#2 Ikon

Ikon

    Harbinger of the Balance

  • Istrum
  • PipPipPipPipPipPip
  • 2788 posts

Posted 31 October 2015 - 02:05

Can you go into a little more detail about what settings you used to cause the FPS to plummet from 60 to 30?


If at first you don't succeed, do it like your mother told you.


#3 Bloodshed

Bloodshed

    Rubber Ducky

  • Istrum
  • Pip
  • 5 posts
  • LocationAustria

Posted 31 October 2015 - 10:43

Can you go into a little more detail about what settings you used to cause the FPS to plummet from 60 to 30?

 

No specific settings required, this will happen with any settings you might use, as long as vsync is enabled and the framerate would drop below whatever your monitors vertical refresh rate might be.

So for instance: vsync locked to 60, rendering output <60  -> fps will drop to 30 instantly, pretty much ruining the experience.

I won't go into technical details here, you can read about that at this location: http://www.anandtech.com/show/2794/2



#4 ShadowNate

ShadowNate

    Arcadia Native

  • Istrum
  • PipPipPip
  • 278 posts

Posted 31 October 2015 - 13:32

No specific settings required, this will happen with any settings you might use, as long as vsync is enabled and the framerate would drop below whatever your monitors vertical refresh rate might be.

However, there have been people, myself included, with vsync enabled and fps values that range within the 40-60 fps interval (or a broader one). It doesn't seem to be a 60 or 30 kind of thing. Or I misunderstood what the issue that you are reporting is.

#5 Bloodshed

Bloodshed

    Rubber Ducky

  • Istrum
  • Pip
  • 5 posts
  • LocationAustria

Posted 31 October 2015 - 18:17

However, there have been people, myself included, with vsync enabled and fps values that range within the 40-60 fps interval (or a broader one). It doesn't seem to be a 60 or 30 kind of thing. Or I misunderstood what the issue that you are reporting is.

 

This might well be the case with nvidia GPU's, because triplebuffering can be enabled within the driver for these cards. If disabled however, the experience will be exactly the same for everyone, due to the way vsync works when only doublebuffered, as explained in detail in the link i posted above.



#6 Olstyle

Olstyle

    Vestrum Crier

  • Istrum
  • PipPipPipPip
  • 597 posts
  • LocationGermany

Posted 31 October 2015 - 18:40

You can't force Triplebuffering in D3D, only in OpenGL.
Have you tried Borderless Window Mode vs. "real" Fullscreen? Afaik windowed is always Triplebuffered whereas Fullscreen Vsync depends on what the developer sets as default.
  • Morten and Bloodshed like this

#7 Ikon

Ikon

    Harbinger of the Balance

  • Istrum
  • PipPipPipPipPipPip
  • 2788 posts

Posted 31 October 2015 - 18:46

That's interesting OldStyle. Naturally, I know how to configure that (*cough* *cough*, ahem, yeah, ;) ), but for the sake of the less knowledgeable, how does someone configure for Borderless Window Mode?


If at first you don't succeed, do it like your mother told you.


#8 Dagget

Dagget

    Arcadia Native

  • Dreamer
  • PipPipPip
  • 371 posts
  • LocationAustin, TX

Posted 31 October 2015 - 18:49

That behavior not observed here, on two PC's

 

I have vsync locked and fps ranges freely from 25-60, depending on where I am, on my big PC using a Radeon 7970, max settings sans bloom.  Same for a secondary PC running an AMD A10-5800k APU - vsync locked and FPS from upper teens to close to 40, medium settings.  My laptop running the game won't generally hit 30 fps, but lives around 20ish on low visual settings.



#9 Olstyle

Olstyle

    Vestrum Crier

  • Istrum
  • PipPipPipPip
  • 597 posts
  • LocationGermany

Posted 31 October 2015 - 18:50

That's interesting OldStyle. Naturally, I know how to configure that (*cough* *cough*, ahem, yeah, ;) ), but for the sake of the less knowledgeable, how does someone configure for Borderless Window Mode?

At first the game was always running in border less window. Later they added setting in game to change to "real" fullscreen. I'm not sure about the exact name in DFC, will have to look that up.

 

Edit: Looked it up and only found a Fullscreen/no Fullscreen option. Im quite sure the "not fullscreen" was borderless on Win7, but I'm, now on Win 10 and there it isn't. So no useable alternative here, sorry.



#10 khh

khh

    Harbinger of the Balance

  • Moderator
  • 7122 posts
  • LocationNorway

Posted 31 October 2015 - 19:17

To enable borderless fullscreen make sure you do not enable the fullscreen option ingame, then go to the Steam library, right click on Dreamfall Chapters, select properties, in the General tab click Set Launch Options, write in "-popupwindow" (without quotes).

 

@Bloodshed Since it looks like this bug may be system dependant, maybe you could post your computer specs and the game's log? How to find/generate the logs are in the FAQ (bottom question of the performance related ones).


  • Bloodshed and Olstyle like this

April Ryan is my friend,
Every sorrow she can mend.
When I visit her dark realm,
Does it simply overwhelm.


#11 Bloodshed

Bloodshed

    Rubber Ducky

  • Istrum
  • Pip
  • 5 posts
  • LocationAustria

Posted 31 October 2015 - 22:04

@Bloodshed Since it looks like this bug may be system dependant, maybe you could post your computer specs and the game's log? How to find/generate the logs are in the FAQ (bottom question of the performance related ones).

 

Well, did some more testing and it seems this only happens in marcuria, everywhere else throughout the game, fps behave perfectly as expected with triplebuffering, only marcuria clearly hints at doublebuffering. That leaves me pretty clueless now to be honest, never experienced something like that before. Maybe some of you guys could check marcuria too ?

I already filed a bug report from within the game, so my specs, logs and a screenshot should already be with the development team.


  • khh and Olstyle like this

#12 Bloodshed

Bloodshed

    Rubber Ducky

  • Istrum
  • Pip
  • 5 posts
  • LocationAustria

Posted 31 October 2015 - 22:24

You can't force Triplebuffering in D3D, only in OpenGL.
Have you tried Borderless Window Mode vs. "real" Fullscreen? Afaik windowed is always Triplebuffered whereas Fullscreen Vsync depends on what the developer sets as default.

 

Thanks, i thought it works in D3D too with nvidia cards.

Thought i tried windowed too, but not quite sure about that now, will try again.

 

Ok, checked again savegame in Marcuria, by the big fountain:

 

FS Vsync: 30fps, no Vsync:58fps

Windowed: 58fps

 

So this clearly points to triplebuffering not being used in FS, but as i mentioned in another post, this only happens in Marcuria....pretty strange.


Edited by Bloodshed, 31 October 2015 - 22:47.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users