Jump to content


Photo

Beta 3.2.0 intro cutscene issues

3.2.0 beta before after

  • Please log in to reply
9 replies to this topic

#1 ShadowNate

ShadowNate

    Arcadia Native

  • Istrum
  • PipPipPip
  • 278 posts

Posted 30 October 2015 - 11:30

The in-game debug tool won't activate for me during the intro cutscene of Book One, so I am reporting here the issues I have found with it.

These are with all settings on high, lens flares disabled. On an AMD HD 7950.

1. One noticeable one is that the fog in the distance is flickering during the first time that the scene opens up and you see all the boats, houses and gathered people. (In the first pic that I am attaching below).

2. The second is that certain objects seem to have a white-ish (it could be pink?) outline where shadows should be. This should be apparent on the images I am attaching below (look the door and door handle where the father stands against (on his 1rst scene), the objects in the doorway behind him (on his 2nd scene), or the frying pans and ladles in the portal scene).

I am including screenshots from the intro cutscene with their (closest I could find) corresponding one from the Windows build in Unity 4. The Unity 4 version is more bright, has more fog and blur for the distance, and doesn't have the white-ish outlines for objects .

I am aware that the team is still working on lighting and other visual improvements for the Unity 5 port, but thought to report these here anyway. Maybe it's just an issue with AMD cards, or Windows 10?

Unity 4 intro boats overview:
iYySz3P.jpg
Unity 5 intro boats overview:
wlgnjJV.jpg

Unity 4 intro floating candle:
bvVL2eO.png

Unity 5 intro floating candle:
2fPgtjA.jpg

Unity 4 father against door 1:
9G0woWx.png

Unity 5 father against door 1:
O43CNOY.jpg

Unity 4 father against door 2:
rzsSfIf.png

Unity 5 father against door 2:
goTudLJ.jpg

Unity 4 intro portal scene:
r83IW5N.png

Unity 5 intro portal scene:
dzcocxK.jpg
  • khh and Mr_Russ like this

#2 Mr_Russ

Mr_Russ

    Vestrum Herald

  • Dreamer
  • PipPipPipPipPip
  • 1563 posts
  • LocationCaddington, Luton, GB

Posted 01 November 2015 - 19:12

ShadowNate, what happens if you turn up your gamma a bit?



#3 CosmicD

CosmicD

    Vestrum Herald

  • Shifter
  • PipPipPipPipPip
  • 1555 posts
  • LocationHasselt, Limburg, Belgium

Posted 01 November 2015 - 19:59

the most of that is missing lights. For example the blue globe you see in the house of all words is supposed to have an ambient light but it's missing, either because they need to swap it with a native unity 5 counterpart for it, I assume this is a dynamic light and not an environmental light. It'll have to be built later if they do another pass and as they do all lights correctly, thjey then will bake other compilations of the map with a fucntioning lightmap ? Dunnot know enough about the engine and don't know if I'm 100% correct though, but it has to do sompething with the light entities.


  • Morten likes this

#4 magic88889

magic88889

    Vestrum Crier

  • Vestrum
  • PipPipPipPip
  • 687 posts

Posted 01 November 2015 - 22:21

Yeah, most of what I've seen from stuff is that the picture of the light is there (you see the flame), but it has no effect on other objects.  So either the element that tells the engine that this emits light is missing, or the mechaninism that tells the engine that certain surfaces should reflect that light (and how, and to what degree) is missing



#5 Ikon

Ikon

    Harbinger of the Balance

  • Istrum
  • PipPipPipPipPipPip
  • 2788 posts

Posted 02 November 2015 - 00:44

Except for the portal scene, which is obviously missing reflected lighting effects, I prefer the look of the U5 images.


  • Mr_Russ likes this

If at first you don't succeed, do it like your mother told you.


#6 ShadowNate

ShadowNate

    Arcadia Native

  • Istrum
  • PipPipPip
  • 278 posts

Posted 02 November 2015 - 11:51

For the Unity 5 ones, like others have said, it seems that there is yet some work to be done on light sources/ lighting and probably model shaders.
Currently, I don't find any of them looking better than the Unity 4 version, but they are not the final versions so I guess I am more interested in pointing out the potential bugs (fog flickering, white edges). I should note here that fog flickering was also an issue with the Linux build on AMD cards (because certain fog volume effects were disabled due to issues with AMD+Unity in Linux).

@Mr_Russ, turning up the gamma just brightens up the image, but they are still dissimilar to the Unity 4 ones.
I am including samples in the spoiler. The screenshots in the original post are with the default 50% gamma.
The ones in the spoiler are with 70% and 90%; I didn't do a 100% because it was way too bright to be noteworthy.
Spoiler

  • Mr_Russ likes this

#7 Dagget

Dagget

    Arcadia Native

  • Dreamer
  • PipPipPip
  • 366 posts
  • LocationAustin, TX

Posted 02 November 2015 - 14:31

A lot of stuff is not enabled or balanced yet in the beta so I don't worry about how things look there at present.  More interested in collision issues and such atm.



#8 Aj17

Aj17

    Arcadia Native

  • Member
  • PipPipPip
  • 448 posts
  • LocationUSA

Posted 02 November 2015 - 18:50

Least it plays smoothly for ya xD chugs at 12fps on me now since updating to the beta lol


jHevh80.jpg


#9 Mixthos

Mixthos

    Rubber Ducky

  • Vestrum
  • Pip
  • 37 posts
  • LocationPaderborn, Germany

Posted 04 November 2015 - 22:19

I've got the flickering fog as well. I was able to report it in-game though.

 

Version: 3.2.1

Graphics Card: GTX 970

OS: Windows 10

 

So it's not just AMD cards.


  • ShadowNate likes this

#10 Mr_Russ

Mr_Russ

    Vestrum Herald

  • Dreamer
  • PipPipPipPipPip
  • 1563 posts
  • LocationCaddington, Luton, GB

Posted 05 November 2015 - 22:56

Flickering fog for me too.

 

Version 3.2.1.4

Graphics cards - 2 * GTX560 Ti in SLI

OS: Windows 10 Pro 64 bit

 

It seems to pulse - flash, flash, pause, flash, flash


  • Mixthos likes this





Also tagged with one or more of these keywords: 3.2.0, beta, before, after

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users