Jump to content


Photo

[Bug Report] Random problems with audio

bug

  • Please log in to reply
9 replies to this topic

#1 davidebarbieri

davidebarbieri

    Rubber Ducky

  • Member
  • Pip
  • 6 posts

Posted 14 June 2015 - 13:45

Hi, I'm experiencing some issues with this game.
The game runs perfectly for 15/20 minutes, then audio randomly stops and does not
work anymore. I've a GTX 660, 8 GB of RAM, a SSD hard drive and Windows 7 64 bit.


Errors in the output log:
 

  1. MissingMethodException: The best match for method SetLookAtMode has some invalid parameter at System.MonoType.InvokeMember (System.String name, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object target, System.Object[] args, System.Reflection.ParameterModifier[] modifiers, System.Globalization.CultureInfo culture, System.String[] namedParameters) [0x00000] in <filename unknown>:0
  2.  
  3.   at UnityEngine.SetupCoroutine.InvokeMember (System.Object behaviour, System.String name, System.Object variable) [0x00000] in <filename unknown>:0
  4. UnityEngine.GameObject:SendMessage(String, Object, SendMessageOptions)
  5. HutongGames.PlayMaker.Actions.SendMessage:DoSendMessage()
  6. HutongGames.PlayMaker.Actions.SendMessage:OnEnter()
  7. HutongGames.PlayMaker.FsmState:ActivateActions(Int32)
  8. HutongGames.PlayMaker.FsmState:OnEnter()
  9. HutongGames.PlayMaker.Fsm:EnterState(FsmState)
  10. HutongGames.PlayMaker.Fsm:SwitchState(FsmState)
  11. HutongGames.PlayMaker.Fsm:UpdateStateChanges()
  12. HutongGames.PlayMaker.Fsm:UpdateState(FsmState)
  13. HutongGames.PlayMaker.Fsm:Update()
  14. PlayMakerFSM:Update()
  15.  
  16.  
  17. KeyNotFoundException: The given key was not present in the dictionary.
  18.   at System.Collections.Generic.Dictionary`2[Pathfinding.Poly2Tri.TriangulationPoint,System.Int32].get_Item (Pathfinding.Poly2Tri.TriangulationPoint key) [0x00000] in <filename unknown>:0
  19.  
  20.   at Pathfinding.Util.TileHandler.CutPoly (Pathfinding.Int3[] verts, System.Int32[] tris, Pathfinding.Int3[]& outVertsArr, System.Int32[]& outTrisArr, System.Int32& outVCount, System.Int32& outTCount, Pathfinding.Int3[] extraShape, Int3 cuttingOffset, Bounds realBounds, CutMode mode, Int32 perturbate) [0x00000] in <filename unknown>:0
  21.  
  22.   at Pathfinding.Util.TileHandler+<LoadTile>c__AnonStoreyCB.<>m__22 (Boolean force) [0x00000] in <filename unknown>:0
  23.  
  24.   at AstarPath.ProcessWorkItems (Boolean force) [0x00000] in <filename unknown>:0
  25.  
  26.  
  27. Could be it caused by the Fabric plugin (?)
  28.  
  29. Fabric: PostEvent[Music] Not handled
  30. Fabric: PostEvent[Sfx] Not handled
  31. Fabric: PostEvent[Voice] Not handled
  32. Fabric: FabricManager initialised (DontDestroyOnLoad flag disabled)


#2 agirlnamedbob

agirlnamedbob

    Harbinger of the Balance

  • Moderator
  • 11227 posts
  • LocationWisconsin, USA

Posted 14 June 2015 - 16:54

I assume based on what you said the audio doesn't cut out in the same spot every time? Like you play for 15-20 minutes, it cuts out, you restart and can play another 15-20 minutes and it cuts out in a different spot? Or is it cutting out at roughly the same spot? 

 

Just to be on the safe side, if you're on Steam, have you tried verifying the game integrity? 

 

I'm not entirely sure what would cause this, but hopefully some people will have some suggestions. Or hopefully Morten can take a look after the weekend. 


Erika - Friendly RTG Moderator

Facebook - Twitter - Steam - Twitch


#3 davidebarbieri

davidebarbieri

    Rubber Ducky

  • Member
  • Pip
  • 6 posts

Posted 15 June 2015 - 01:03

Nope, it seems random to me. This time I tried it on another PC and got the same problem:

an AMD octa-core, GTX 970 and 8 GB of RAM, a "normal" hard drive (not SSD).

This time after a hour of playtime.

 

The funny fact is that it happened during a conversation (with Queenie), and for the rest of the dialogue

both the main character and the old chinese lady were holding the mouth opened without moving lips.

So I believe this is not just a problem with my audio card (I tried it on two different PCs anyway) or whatever,

since it seems that the lip sync controller freezes as well since it doesn't receive audio informations.

 

Here the last part of my output-log:

 
FSM Zoe talks to Queenie in state Scene finished action index 10
 
(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)
 
FSM Zoe talks to Queenie in state Scene finished action index 11
 
(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)
 
FSM Zoe talks to Queenie in state Scene finished action index 12
 
(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)
 
FSM Zoe talks to Queenie in state Scene finished action index 13
 
(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)
 
FSM Zoe talks to Queenie in state Scene finished action index 14
 
(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)
 
FSM Zoe talks to Queenie in state Scene finished action index 15
 
(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)
 
FSM Zoe talks to Queenie in state Scene finished action index 16
 
(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)
 
FSM Zoe talks to Queenie in state Scene finished action index 17
 
(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)
 
FSM Zoe talks to Queenie in state Scene finished action index 18
 
(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)
 
FSM Zoe talks to Queenie in state Scene finished action index 19
 
(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)
 
FSM Zoe talks to Queenie in state Scene finished action index 20
 
(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)
 
FSM Zoe talks to Queenie in state Next Stage finished action index 0
 
(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)
 
FSM Zoe talks to Queenie in state Next Stage finished action index 1
 
(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)
 
FSM 2.2.4 Controller in state Setup Nela finished action index 0
 
(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)
 
FSM 2.2.4 Controller in state Setup Nela finished action index 1
 
(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)
 
FSM 2.2.4 Controller in state Setup Nela finished action index 2
 
(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)
 
FSM 2.2.4 Controller in state Setup Nela finished action index 3
 
(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)
 
FSM 2.2.4 Controller in state Setup Nela finished action index 4
 
(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)
 
FSM 2.2.4 Controller in state Setup Nela finished action index 5
 
(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)
 
FSM 2.2.4 Controller in state Setup Nela finished action index 6
 
(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)
 
FSM Wardrobe Girl in state Standby finished action index 0
 
(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)
 
FSM 2.2.4 Controller in state Setup Nela finished action index 7
 
(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)
 
Running conversation from: Before starting work
 
(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)
 
Running conversation from: Starting work
 
(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)
 
Running conversation from: After starting work
 
(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)
 
Running conversation from: Reflections on therapy
 
(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)
 
Running conversation from: After Nela Bites
 
(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)
 
Running conversation from: Leaving the Hand That Feeds
 
(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)
 
Running conversation from: On the nature of my job
 
(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)
 
Running conversation from: Notes on today's assignment
 
(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)
 
Running conversation from: Afterwork
 
(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)
 
Running conversation from: Thoughts on visit with Queenie
 
(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)
 
FSM 2.2.4 Controller in state Setup Nela finished action index 8
 
(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)
 
FSM 2.2.4 Controller in state Save - After Queenie finished action index 0
 
(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)
 
Setting Chapter: 2.2.4.3
 
(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)
 
FSM 2.2.4 Controller in state To Nela finished action index 0
 
(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)
 
FSM Zoe talks to Queenie in state Next Stage finished action index 2
 
(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)
 
FSM Zoe talks to Queenie in state Next Stage finished action index 3
 
(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)
 
FSM Nela Encounter in state Standby finished action index 0
 
(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)
 
FSM AdBot 4 in state Patrolling finished action index 0
 
(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)
 
Game saved in 0.341s
 
(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)
 
Unloading 1 Unused Serialized files (Serialized files now loaded: 3 / Dirty serialized files: 0)
 
Unloading 3 unused Assets to reduce memory usage. Loaded Objects now: 152983.
Total: 121.119537 ms (FindLiveObjects: 12.376604 ms CreateObjectMapping: 4.395266 ms MarkObjects: 103.215179 ms  DeleteObjects: 0.418753 ms)
 
FSM MusicController in state On finished action index 0
 
(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)
 
FSM MusicController in state On finished action index 1
 
(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)
 
Clearing out all cInput related values from PlayerPrefs
 
(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)
 
UnloadTime: 390.800446 ms
Fabric: PostEvent[Music] Not handled
 
(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)
 
Fabric: PostEvent[Sfx] Not handled
 
(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)
 
Fabric: PostEvent[Voice] Not handled
 
(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)
 
Fabric: FabricManager initialised (DontDestroyOnLoad flag disabled)
 
(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)
 
Unloading 2 Unused Serialized files (Serialized files now loaded: 0 / Dirty serialized files: 0)
 
Unloading 6843 unused Assets to reduce memory usage. Loaded Objects now: 21228.
Total: 109.057320 ms (FindLiveObjects: 1.222681 ms CreateObjectMapping: 3.318424 ms MarkObjects: 39.069180 ms  DeleteObjects: 64.725403 ms)


#4 khh

khh

    Harbinger of the Balance

  • Moderator
  • 7118 posts
  • LocationNorway

Posted 15 June 2015 - 08:51

That is super weird, I haven't seen anyone else encountering that problem before. And on the other computer it's a complete new install, you didn't just copy the installation over? If so, it can't be explained by missing assets either.

 

Maybe you could post the whole log? You can attach it to your post by using the More Reply Options button. Hopefully Morten have some insight into what's going on here.


April Ryan is my friend,
Every sorrow she can mend.
When I visit her dark realm,
Does it simply overwhelm.


#5 davidebarbieri

davidebarbieri

    Rubber Ducky

  • Member
  • Pip
  • 6 posts

Posted 15 June 2015 - 09:27

Oh, sure. It a fresh new install from Steam.

The only thing that connects both playtimes I assume is the savegame

(since it is automatically synchronized by Steam Cloud).

 

This is the output_log from the first PC (the one with the GTX 660):

http://pastebin.com/TXuGmSbw

 

I closed it just after the problem.



#6 davidebarbieri

davidebarbieri

    Rubber Ducky

  • Member
  • Pip
  • 6 posts

Posted 15 June 2015 - 11:34

oh, anyway,

by closing and reopening the game, the same part plays correctly with audio.



#7 Morten

Morten

    RTG Programmer

  • RTG Staff
  • 1061 posts
  • LocationOslo, Norway

Posted 15 June 2015 - 11:47

So you were able to correct the issue and get the game working correctly again?

Seems like a pretty rare issue. However, it's pretty unsettling that it happened on two different computers. Might indicate an issue with that specific savegame file as mentioned.
Definitely something we'll look into.

Thanks for the report, and very helpful that you posted the logs from both sessions (although the second one didn't seem to have any specific errors in it). :)

Red Thread Games PR0grammer & Naturally Selected Part-Time "Keep Track of Forum"-person / Community Overseer


#8 davidebarbieri

davidebarbieri

    Rubber Ducky

  • Member
  • Pip
  • 6 posts

Posted 15 June 2015 - 17:11

Oh, nono, I mean that it happens randomly,

but if I quit, reopen the game and hit continue then the issue doesn't happen on the same part of the game;

so I'm still able to play it, although it is a bit annoying.

 

Thanks for your time!



#9 Morten

Morten

    RTG Programmer

  • RTG Staff
  • 1061 posts
  • LocationOslo, Norway

Posted 17 June 2015 - 10:47

I see. That's really unfortunate.  :wacko:

I'd recon it may happen because of some incompatibility with your sound card/audio driver and it's not picked up and recorded as an error in the engine, but I can't say anything for certain at this stage.

 

As mentioned, we'll look into it as soon as we are able to. Thanks again for your patience. :)


  • davidebarbieri likes this

Red Thread Games PR0grammer & Naturally Selected Part-Time "Keep Track of Forum"-person / Community Overseer


#10 davidebarbieri

davidebarbieri

    Rubber Ducky

  • Member
  • Pip
  • 6 posts

Posted 17 June 2015 - 17:24

I see. That's really unfortunate.  :wacko:

I'd recon it may happen because of some incompatibility with your sound card/audio driver and it's not picked up and recorded as an error in the engine, but I can't say anything for certain at this stage.

 

As mentioned, we'll look into it as soon as we are able to. Thanks again for your patience. :)

 

Don't worry, it's fine :)

 

I just give you some additional infos, in case you'll experience this with some other player:

the two PCs have a very different hardware (the first is a very old notebook PC - Acer 5920G),

while the 2nd is quite new (the motherboard is a Sabertooth 990fx); the first has Win7, the latter Win8.1.

 

Before happening, it has some weird slow-downs (with discountinous sound) and then the audio stops

(last time it didn't stopped roughly, on the coutrary it seemed that some background sound continued for some seconds,

audio sources didn't stopped all in the same moment).

It seems to me like a sort of leak (caused by Fabric?), since it seems to happen after some playtime

(especially when I see new things, see cinematics: probably it is connected with the amount of new audio resources

loaded or played). I don't know,

maybe Audio Sources or audio resources which are not deleted/freed in scene which accumulate, or something like that.

(I'm not trying to be pedantic, just trying to help, since these random problems are hard to solve,

especially when the developer can't directly see their effects ;P).


  • Morten and Tina like this





Also tagged with one or more of these keywords: bug

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users