Jump to content


Photo
- - - - -

Bugs playing on Mac

Bugs Performance MacOSX

  • Please log in to reply
3 replies to this topic

#1 Bluelikevelvet

Bluelikevelvet

    Rubber Ducky

  • Istrum
  • Pip
  • 18 posts
  • LocationSpain!

Posted 19 March 2015 - 15:33

Hi there! 

I have been experiencing many bug encounters while playing on my Mac. I managed to play Book1 after the patches, so I was super glad I could play smoothly Book2 without the performance issues I had when Book 1 was published. But this time those bugs are "event related". I will post the ones I could see in the few minutes I could play of the game. I hope this is helpful for other mac users. I also hope this would help developers somehow  :ehehe:

 

There we go:

 

1. Bip does not appear behind the bushes passed the ghetto gate. In my case, I can only hear him say: "Are you going back to Oldtown? I will wait here", whenever I approach the gates again. But no actual trace of him. Which is a shame because I kind of love this kiddo. I tried going everywhere, stand where the bushes are, running back and forth. I had Kian dancing around and nothing popped up. I also loaded a previous saving and still the problem was there. 

 

2. Explosion in the Harbor does not occur. This is a pretty strange bug. I made sure the guard didn't see me and placed all the items. When I ignited the fire, the screen turned out white and no shortcut of the explosion and post burnout appeared right after. The items I placed disappeared and nothing was burning. I tried to search the items again, and I couldn't  :tear:

 

3. The Mole likes to make pitches. This is a quite funny bug. When I manage to fulfill the task the Mole asks for (thank God), I return with the mission done and the Mole talks to me. When the dialogue is done and Kian is about to leave, she starts talking again, and I have to stand there talking the same dialogue twice. I know it's a bug because I loaded previous savings and still it happened. 

 

As you can see, these bugs cannot let me go further in the game, so I am quite stuck there. I know my OSX is a bit old, but I have a lot of RAM and I could play Book1 safely after the patches :3 so I know it has to work out just fine in my computer. Have you experienced other issues? Let's talk about these thingies so the awesome team is aware. 

 

PS: I love the game so far that I'm dying to play it hehe


:crow: "You know that Rubber Ducky comes from April Ryan's appartment right? RIGHT?!"


#2 Indrid Cold

Indrid Cold

    Harbinger of the Balance

  • Vestrum
  • PipPipPipPipPipPip
  • 3099 posts

Posted 19 March 2015 - 15:36

Hi there,

 

Two of those things have been reported, and there's things to do:

 

1) This will be fixed in an update coming out this week. For now you can go to where he'd take you as a workaround, and he'll appear there. Someone has a map but I can't find it right now, sorry.

2) Not a bug, AFAIK. I think you didn't make sure the explosion didn't kill you. EDIT: Unless by "the items disappeared" you mean they're not in your inventory either, which would be a bug!

3) This one I've not heard before.



#3 khh

khh

    Harbinger of the Balance

  • Moderator
  • 7118 posts
  • LocationNorway

Posted 19 March 2015 - 15:44

1) It's me. I have a map. If you talk to Bip and ask him to follow you to the National Front assembly, and then make your way to the location indicated on your own, he should reappear.

 

Spoiler

 

2) Can't you pick up the items again? Remember that Kian has to look at the shipment before he's able to do so.

 

3) I hadn't heard of that one either. Strange.


  • Tina likes this

April Ryan is my friend,
Every sorrow she can mend.
When I visit her dark realm,
Does it simply overwhelm.


#4 Bluelikevelvet

Bluelikevelvet

    Rubber Ducky

  • Istrum
  • Pip
  • 18 posts
  • LocationSpain!

Posted 19 March 2015 - 16:57

Hey there! Well, in fact I went to the Front National Assembly on my own and he's not there either and I cannot interact with the guy standing there. That is why I think in some cases the Bip problem is more important than expected. And no... I cannot pick up the items again, and they do not appear in my inventory. The funny thing is that i was out of the harbor before the explosion ocurred, but was pretty close to the gate. Could it be that? I will try again that part :) 

 

Thank you, mates!


:crow: "You know that Rubber Ducky comes from April Ryan's appartment right? RIGHT?!"






Also tagged with one or more of these keywords: Bugs, Performance, MacOSX

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users