Jump to content


Photo
- - - - -

Performance horrible on Windows 8.1, core i5 760 @3.6Ghz, GTX 760


  • Please log in to reply
29 replies to this topic

#1 Savio

Savio

    Rubber Ducky

  • Member
  • Pip
  • 5 posts

Posted 25 January 2015 - 21:11

Hi Guys,

 

before I go on I'd like to state that I read ALL forum topics on performance. I literally spent days crawling through all pages (here, steam, gog, all google hits) that are remotely related to performance. I updated my drivers (all of them) to the newest versions. I decreased resolution. I double checked all my settings. PC is set to maximum performance. I tried assigning single core / multi core. Fooled around with each setting in Nvidia driver settings. I did everything.

 

Now that this is out of the way I'd like to rant a little bit.

 

I love the longest journey. It is one of my favorite games. I also loved the sequel. So this is why I was excited when DFC was finally released.

Unfortunately on my rig it is not playable. My rig is an i5 760 running at 3.6Ghx, 16 GB ram, GTX 760.

The intro runs at around 10fps. No kidding.

First part was kinda playable with 18fps in average... until I hit the chapter where I had to escape a cellar (prison?). It was so slow I had to shut down my pc, smash the wall behind me and cry in the bathroom.

Why do you do that to me? I mean, my system might not be the fastest out there but it is fast enough to handle all current games. Shadow of Mordor for instance is running in highest settings at 1920 resolution. 

 

So why is it that DFC, with let's say so-so graphics runs so slow.

Anybody out there with a similar rig with any solution?

 

Best

Sav



#2 Vainamoinen

Vainamoinen

    Harbinger of the Balance

  • Vestrum
  • PipPipPipPipPipPip
  • 6169 posts

Posted 25 January 2015 - 21:20

That's... about the most extreme case I've seen yet. Yes of course you should be able to run Chapters at maxed settings, no problem.

 

The first thing I'd try is to turn on V-sync in the main menu. But that will hardly be a miracle solution of any kind.


Hey Ubisoft, you can keep your "seamless vast online GTA in space" to yourselves. Signed, one of the greatest Beyond Good & Evil fans alive.


#3 Kari2

Kari2

    Vestrum Crier

  • Minstrum
  • PipPipPipPip
  • 910 posts
  • LocationSan Francisco Bay Area

Posted 25 January 2015 - 21:23

Hi Guys,

 

before I go on I'd like to state that I read ALL forum topics on performance. I literally spent days crawling through all pages (here, steam, gog, all google hits) that are remotely related to performance. I updated my drivers (all of them) to the newest versions. I decreased resolution. I double checked all my settings. PC is set to maximum performance. I tried assigning single core / multi core. Fooled around with each setting in Nvidia driver settings. I did everything.

 

Now that this is out of the way I'd like to rant a little bit.

 

I love the longest journey. It is one of my favorite games. I also loved the sequel. So this is why I was excited when DFC was finally released.

Unfortunately on my rig it is not playable. My rig is an i5 760 running at 3.6Ghx, 16 GB ram, GTX 760.

The intro runs at around 10fps. No kidding.

First part was kinda playable with 18fps in average... until I hit the chapter where I had to escape a cellar (prison?). It was so slow I had to shut down my pc, smash the wall behind me and cry in the bathroom.

Why do you do that to me? I mean, my system might not be the fastest out there but it is fast enough to handle all current games. Shadow of Mordor for instance is running in highest settings at 1920 resolution. 

 

So why is it that DFC, with let's say so-so graphics runs so slow.

Anybody out there with a similar rig with any solution?

 

Best

Sav

 

Start turning off graphic features: Anti-Aliasing, Depth of Field and sync.  Set shadows at about 3m. Change your display settings to a lower settings and check the "Do not Scale". Set the game graphics setting as "Full Screen" and the same resolution as your display. You can keep the quality setting on "High".

 

If this doesn't do it, set the display at an even lower resolution.



#4 Mr Moo

Mr Moo

    Harbinger of the Balance

  • Vestrum
  • PipPipPipPipPipPip
  • 2096 posts
  • LocationNorway

Posted 25 January 2015 - 21:27

PC is set to maximum performance. I tried assigning single core / multi core. Fooled around with each setting in Nvidia driver settings. I did everything.

So, in Windows Power Options you have tried using the "High Performance" plan?

 

I wouldn't try running the game single core, as it's very CPU dependent.


  • agirlnamedbob likes this

#5 Savio

Savio

    Rubber Ducky

  • Member
  • Pip
  • 5 posts

Posted 25 January 2015 - 23:41

Hi guys,

 

I thought that was obvious that I already started turning off features =) 

thanks for the replies.

 

1. PC was already set to high performance. No difference.

2. V-Sync makes no difference. Tried setting on/off, forced driver setting, without driver etc.

3. Anti-Aliasing surprisingly makes not much of a difference.

4. Shadows did. But then the game looks really crappy. Should be around 5 fps.

5. Resolution set to 1366*768 and everything on low. makes it kinda playable. Still dropping framerates. Graphics is set to full screen already. If I'd set it to same resolution it would be 2560x1440.

6. Interestingly when I boot to my Hackintosh the game kinda runs smoothly with some drops to around 20 fps. (1920 and everything on high).



#6 agirlnamedbob

agirlnamedbob

    Harbinger of the Balance

  • Moderator
  • 11228 posts
  • LocationWisconsin, USA

Posted 25 January 2015 - 23:52

Yeah, at this point I'm not entirely sure what to offer for a suggestion here. There were definitely people having these issues early on, but I thought that most of these bizarre "There's no reason I should be having performance issues" issues were fixed with the latest patches. So as long as you're running version 1.1.3, I have no idea what's going on.  :blink:

 

Maybe Morten will have some suggestions when he gets into the office on Monday? He might ask you to post an output log or something.

 

Sorry we can't be of more help. Though someone else might have something. (Sundays are kind of quiet days around here.) 


Erika - Friendly RTG Moderator

Facebook - Twitter - Steam - Twitch


#7 CosmicD

CosmicD

    Vestrum Herald

  • Shifter
  • PipPipPipPipPip
  • 1555 posts
  • LocationHasselt, Limburg, Belgium

Posted 26 January 2015 - 00:00

Well, that cpu is like 2 generations back, and I've got one from the previous generation and before the game got optimized, Europolis ran horrible too, now it's like 45-55 fps. It's a well known fact that the unity engine in combination with a huge area like Europolis is kinda CPU bound. I have a gtx 970, an i5 2400 and europolis runs a bit worse than watch dogs, so go figure.

I think like if you'd have a modern i7 you'll really see a big difference with the same videocard.

Ofcourse they already optimized the game a whole lot and they can maybe still get something out of it,

I'm not sure where some culprits still lie but if you know that i'm having 18 fps in the house of all worlds at 4k, and when I turn AA and AF off, it's a huge difference. In europolis it's not so much a difference.



#8 agirlnamedbob

agirlnamedbob

    Harbinger of the Balance

  • Moderator
  • 11228 posts
  • LocationWisconsin, USA

Posted 26 January 2015 - 00:10

Well we all know that the Unity engine has optimization issues, but that doesn't change the fact that this computer meets specs and should run it without issues. 

 

I'm on a 3+ year old laptop with an i5 2.30GHz and a lower graphics card than the one cited in this thread and I can still run the game fine at this point.


Erika - Friendly RTG Moderator

Facebook - Twitter - Steam - Twitch


#9 Lee-m

Lee-m

    Harbinger of the Balance

  • Vestrum
  • PipPipPipPipPipPip
  • 1866 posts
  • LocationYorkshire, England

Posted 26 January 2015 - 00:26

Thats an odd one. Despite the i5 760 being one of the oldest i5s it still a strong performer, and more than adequate for this game.

The only advice I can think of is, stick with the steam version and maybe try the beta channel to get a different version (you never know your luck), and make sure you switch any anti virus off and see how that goes. maybe its some software you have running that screwing things up.

 

might be worth a defrag if you dont have an ssd (I know.. really scraping the bottom of the barrel for ideas there).


  • agirlnamedbob likes this

#10 Savio

Savio

    Rubber Ducky

  • Member
  • Pip
  • 5 posts

Posted 26 January 2015 - 00:28

Cpu generation don't matter that much. Mine is also overclocked to 3.6Ghz. I know that it is not bottlenecking here. When I check cpu usage it stalls at around 20%.
 
I also just got to Europolis. As said before: On my hackintosh (which is the same hardware) everything runs fine with some occasional drops to around 20fps which is still much better than with Windows 8.1.
Don't know what's wrong here, because I updated everything. Must be software related. But then.. this is a clean install. I don't have AV or some other clients, etc. running in the background. Harddrive is an Intel SSD, but this cannot seriously bottleneck =/ 
 
Anyway I gonna keep playing on the hackintosh. Gonna try on my MacBook (late 13) later if it works with Bootcamp/Windows. 
 
What's up with Unity and its horrible performance on some systems.. I will never ever buy or recommend an Unity game again. =(
 

 

Btw. these are the programs installed: 

http://postimg.org/image/htk7v5pnt/

Cheers



#11 Olstyle

Olstyle

    Vestrum Crier

  • Istrum
  • PipPipPipPip
  • 597 posts
  • LocationGermany

Posted 26 January 2015 - 08:38

This is definately an software issue. Since the CPU seems to perform ok, the GPU is the next to check. You could try Afterburners Ingame Overlay to see if it clocks up fine.

#12 futon

futon

    Rubber Ducky

  • Member
  • Pip
  • 2 posts

Posted 27 January 2015 - 14:06

I have a significantly less powerful machine than yours, but I've noticed the same performance issues.  I know that isn't note-worthy, but my experience mirrors the pattern you allude to in your first post.  Most of the other posts are complaining about poor performance in Europolis, but it's been the most playable area for me, so far.  

 

I'm running a Core i3 @ 3.3Ghz, 6GB of ram, and a GTS XXX (precise model eludes my memory at this moment; I'll look it up tonight).   Anyways, very different specs, but my experience is very similar:

 

* Extreme choppiness during the intro; well under 10 FPS.

* Very smooth and playable while Zoe is in the undreaming.

* Extreme choppiness with Kian in the tower; nearly unplayable.

* Extreme choppiness with Zoe in therapy.

* Very smooth and playable in Propast.

 

Settings:

 

1366x768

Quality Medium

Anti-Aliasing Medium

SSAO Low

Depth-of-Field Off

Bloom, Lens flares On

 

It seems to me that there's something very specific with the intro, the tower sequence, and the therapist's office.   Possibly heavy use of particle effects; smoke & flame in the first two, and maybe something to do with the rain-streaked windows in the office?  The thing about the office is that the performance was horrendous even when the windows weren't in frame.

 

Anyhow, I'm enjoying the game, but wish the experience was more consistent.

 

I'm running under linux (with the 3.31 drivers), and have a glmark2 score of 4000+.



#13 Morten

Morten

    RTG Programmer

  • RTG Staff
  • 1061 posts
  • LocationOslo, Norway

Posted 27 January 2015 - 14:25

Only thing I can think of that is common for two of those scenes, the intro (Swamp City) and Dr. Roman's office, is that they use some reflection shaders. On the floor in Dr. Roman's office, and on the water in Swamp City.

Friar's Keep might utilize a few more particle effects than other scenes currently, but that's only some rising smoke and flame particles along the walls. 

 

These scenes are maybe the ones that are the least reiterated on in terms of optimization at this point, but we will do that at some point.

However, with Savio's rig I really can't see why there should be any problem with these scenes. We have machines at the same level or worse in terms of hardware in our office that runs these totally fine. And they're running Windows 8.1 as well (apart from Mac and Linux machines of course).

 

futon, your rig should also do pretty well, but will of course be more susceptible to graphical issues. Still interesting to see how bad the performance is in some places that should be rather easy to process.

 

I can't really say at this time why you guys have these issues, but thank you very much for the reports. It really helps us with identifying "bottlenecks" in our game. :)


Red Thread Games PR0grammer & Naturally Selected Part-Time "Keep Track of Forum"-person / Community Overseer


#14 futon

futon

    Rubber Ducky

  • Member
  • Pip
  • 2 posts

Posted 27 January 2015 - 14:37

Thank you kindly for the response, Morten.  For what it's worth, I do seem to recall some reflective puddles on the floor of the Keep, and the tried and true look-at-the-floor-to-improve-performance trick didn't work very well.


  • Morten likes this

#15 magritte

magritte

    Vestrum Crier

  • Member
  • PipPipPipPip
  • 926 posts

Posted 31 January 2015 - 18:17

Have you had any luck?  I'm puzzled by your problem because I have a very similar set up (i5-4670 and Geforce 760).  I wondered if the latest nvidia drivers might have broken something but I wandered around Europolis for a while and never saw my framerate drop below 35 (1680x1050, high quality settings), so it's not that.  I haven't checked the Keep, but I don't recall having trouble there even with my old machine (WinXP-32, Radeon 4850, Core 2 Due QE-8500).



#16 GistOfSpirit

GistOfSpirit

    Harbinger of the Balance

  • Vestrum
  • PipPipPipPipPipPip
  • 3102 posts

Posted 31 January 2015 - 23:17

Sorry if it's been mentioned, but have you checked what else is running on your computer? Either a legitimate process or some kind of malware could be using up your C- or GPU.



#17 Savio

Savio

    Rubber Ducky

  • Member
  • Pip
  • 5 posts

Posted 01 February 2015 - 00:29

Unfortunately I didn't have any luck.

Thanks for the guys trying to help but I'd also appreciate if people would read the thread. I don't have any processes running in the background. Being a software developer I can handle this pretty well =)

 

Regarding GPU Usage: It is 100%. As of now I am pretty sure it is a sofware bug. Unfortunately not sure if related to Windows or to the Nvidia Drivers (347.25).

 

Cheers



#18 Olstyle

Olstyle

    Vestrum Crier

  • Istrum
  • PipPipPipPip
  • 597 posts
  • LocationGermany

Posted 01 February 2015 - 00:44

Regarding GPU Usage: It is 100%. As of now I am pretty sure it is a sofware bug. Unfortunately not sure if related to Windows or to the Nvidia Drivers (347.25).

I didn't ask about usage, I asked about clocks. For any kind of reasons (mostly defective driver install or blocked fan), your GPU might stay at idle clocks.

To rule out Chapters as the main source, you might want to try 3DMark to see whether your system performs normally. If it performs well there, the next try could be unity's heaven demo to see if it is engine-related.
  • Mr Moo likes this

#19 khh

khh

    Harbinger of the Balance

  • Moderator
  • 7122 posts
  • LocationNorway

Posted 01 February 2015 - 01:14

Unfortunately I didn't have any luck.

Thanks for the guys trying to help but I'd also appreciate if people would read the thread. I don't have any processes running in the background. Being a software developer I can handle this pretty well =)

 

Regarding GPU Usage: It is 100%. As of now I am pretty sure it is a sofware bug. Unfortunately not sure if related to Windows or to the Nvidia Drivers (347.25).

Yeah, it's got to be a software issue somewhere. My rig is weaker than yours on every single point, but the game is perfectly playable dipping to 18 fps some places in Europolis (without my HD 6870 hitting 100 % utilization).

 

One thing you can try and check is if you power settings have gotten messed up somehow, so the computer isn't in Balanced or High Performance mode, but rather something like Power Saver. I think we saw one case where this caused a powerful machine to slog.

 

I'd double check that the clock speed on the GPU is scaled correctly, like Olstyle mentions.

 

Then if none of those work I'd try if Windowed worked better than Fullscreen (you can get borderless fullscreen with the Unity commandline arguments), and maybe also see if forcing OpenGL helps. 


April Ryan is my friend,
Every sorrow she can mend.
When I visit her dark realm,
Does it simply overwhelm.


#20 Savio

Savio

    Rubber Ducky

  • Member
  • Pip
  • 5 posts

Posted 01 February 2015 - 11:51

I checked the clock with Afterburner and it looks fine. Switched to window mode already and that did nothing. Also I like to state that all resolutions don't seem to have a big impact on overall performance. It must be something else. All the benchmarks run in the regions for a gtx 760. I was worried if there is something wrong also but as of now all games except DF:C perform perfectly fine.

 

Yesterday I finished 'Life is strange' Episode 1 in highest settings 2560x1440 which runs flawlessly. Today I installed Book of unwritten tales 2. The former uses the Unreal Engine, the latter uses Unity. Incredibly it also runs smooth in ultra settings with 8xAA.

 

 -force-opengl also didn't help. I think I will boot up to the hackintosh and continue playing there. I am giving up officially. Thanks for your help =)

 

Hopefully the tips posted here can help other players.

 

Cheers


  • khh likes this




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users