Jump to content


Photo

First tries with the steam beta.

Beta v1.1.3

  • Please log in to reply
30 replies to this topic

#1 CosmicD

CosmicD

    Vestrum Herald

  • Shifter
  • PipPipPipPipPip
  • 1555 posts
  • LocationHasselt, Limburg, Belgium

Posted 05 December 2014 - 21:18

I installed the beta trough steam and

I started it up and it was still in this semi exclusive windowed mode/full screen ish mode. (changing to 4k wasn't possible)

So I had to disable fullscreen, apply, press alt tab, alt tab again to make it full screen windowed and then when I pressed fullscreen it went to the exclusive mode and I could change to 4k. (note that I don't have a 4k screen but my videocard can do that DSR mode. It's noticable because the steam overlay becomes very small :)

So I wanted to see how it looked in Europolis and I was amazed that it wasn't a slideshow as I expected. But you know what the kicker is ? In 4k, I have like 37 fps, which isn't much lower than 1080. But in the house of all world i get a whopping 18 FPS, which is much less than the 58ish fps i have in 1080. That puzzles me.

My system specs are attached

Attached Files



#2 LeChuck

LeChuck

    Rubber Ducky

  • Drachkin
  • Pip
  • 23 posts
  • LocationArcadia

Posted 06 December 2014 - 00:17

I am at Dr. Romans office in 1.1.3 :

 

Great Patch (1.1.3) - nice V-Sync ! love it so far.

Some strange things I noticed:

-Nvidia 3D Vision can be activated now. But the result is just meh. I could not let it be turned on. (because of the shadows maybe?)

 

-When I don`t say a word to the warden at the beginning with Kian, the game shows "sighs" as subtitle after the last option to choose silence ! My subtitles are turned off.

 

-Interlude in the emissary`s office: The door that swings open has no textures. I did not notice this before.

 

All minor bugs! Thanks for the BETA. :)


  • Morten likes this
Ragnar Tornquist (Twitter): "Kiss or no kiss, he's always been (and will always be) gay!"

#3 loranna238

loranna238

    Vestrum Crier

  • Shifter
  • PipPipPipPip
  • 658 posts
  • LocationSomewhere Between the Earth and the Sun

Posted 06 December 2014 - 02:00

Sorry - what's this about?  I must be behind on something - or is it a new steam client you're talking about?



#4 agirlnamedbob

agirlnamedbob

    Harbinger of the Balance

  • Moderator
  • 11228 posts
  • LocationWisconsin, USA

Posted 06 December 2014 - 02:05

RTG is allowing users to beta test performance patches via Steam. This arose partly out of discussions in this thread. Morten's got a post about it here


Erika - Friendly RTG Moderator

Facebook - Twitter - Steam - Twitch


#5 Mr_Russ

Mr_Russ

    Vestrum Herald

  • Dreamer
  • PipPipPipPipPip
  • 1572 posts
  • LocationCaddington, Luton, GB

Posted 06 December 2014 - 19:55

Where is the choices toggle? I really didn't want to see the consequences message once I'd chosen "past" in Storytime.

 

 

-When I don`t say a word to the warden at the beginning with Kian, the game shows "sighs" as subtitle after the last option to choose silence ! My subtitles are turned off.

My subtitles are off too. I didn't see anything and my choices were silence / beheading / silence.



#6 khh

khh

    Harbinger of the Balance

  • Moderator
  • 7122 posts
  • LocationNorway

Posted 06 December 2014 - 20:08

Where is the choices toggle? I really didn't want to see the consequences message once I'd chosen "past" in Storytime.

Why do you ask? I can't see that they say they've added that in the patch notes. 


April Ryan is my friend,
Every sorrow she can mend.
When I visit her dark realm,
Does it simply overwhelm.


#7 Mr_Russ

Mr_Russ

    Vestrum Herald

  • Dreamer
  • PipPipPipPipPip
  • 1572 posts
  • LocationCaddington, Luton, GB

Posted 06 December 2014 - 20:10

Oh. I thought we were getting it since it wasn't part of 1.0 and had been discussed subsequently. I will be disappointed if we can't turn that off.



#8 Lee-m

Lee-m

    Harbinger of the Balance

  • Vestrum
  • PipPipPipPipPipPip
  • 1869 posts
  • LocationYorkshire, England

Posted 07 December 2014 - 16:52

I'm not convinced that the new Exclusive Mode is working for me. I tried dropping the game back into a window, then back to full screen, but my mouse still freely wanders out onto my 2nd monitor on the title screen, and on the options screen in game (hitting esc).
 
On the face of it v-sync seems to be working perfectly, and if anything has fixed a few out of time events and animations that got introduced in the performance patch as my fps often raced off to 300fps at times.
Now it seems locked to a solid 60fps for me so far.
 
But this is just my first run impression, I haven't got to Europolis yet to test things out there.

-When I don`t say a word to the warden at the beginning with Kian, the game shows "sighs" as subtitle after the last option to choose silence ! My subtitles are turned off.

I can confirm that minor bug. I picked Silence every time.

 
 
i5 @4.4ghz, gtx 980 4gb, 16gig sys ram.
Beta v1.1.3

#9 Lee-m

Lee-m

    Harbinger of the Balance

  • Vestrum
  • PipPipPipPipPipPip
  • 1869 posts
  • LocationYorkshire, England

Posted 07 December 2014 - 18:03

Running down from Nela's kart towards the stairs that leads to the water front, you can have Zoe scale the building by sticking to the wall on the small ramp as you go around.

You can then drop back behind the scenery again and go running around.


Seems like all the music has been restored. All of it seems to work for me.

Attached Files



#10 CosmicD

CosmicD

    Vestrum Herald

  • Shifter
  • PipPipPipPipPip
  • 1555 posts
  • LocationHasselt, Limburg, Belgium

Posted 10 December 2014 - 13:49

THere seems to be a new beta rightnow:

4k experience is pretty good in europolis, 21-32fps , which is good considering it's you know.. 4k and my cpu isn't the latest generation i5 but the pervious one.

But still, why by the balance would the house of all world lag so much ? There's not much characters running around, it's like not big at all and just a few rooms. Is there  a faulty light source ? Stuff leaking into the void maybe ? (not sure how unity works but, can't understand why such a small area would lag and europolis doesn't)

Something I also want to point out that in 4k the interaction interface icons and texts are very very small. Maybe that's because I'm using DSR mode and I actually don't have a 4k monitor.  But the subtitles seem ok, it's just the interface that doesn't maintain it's size. It's a bit hard if you want to interact with puzzles you havent tried yet:

http://cloud-4.steam...ABF5637118D721/

Further testing:

story time 50-60 fps
http://cloud-4.steam...C16B08C86665DE/

Friar's keep: 15-22 fps.

And I notice a nasty problem with this patch (both in 4k and 1080), when I press esc (for the menu) and press esc again it somehow hangs the game and doesn't resume , I have to end the process. The particular problem is that the menu is about to go away on pressing esc the second time, but the game gets stuck and whatever post processing is used to darken and desaturate the screen when in pause doesn't dissapears but hangs.

I started a new game and in chapter 0 you can press esc and return to the game anytime, but starting from adrift, doing so will hang the game.

Could this have anything to do with old saves or conflicting game settings ?



#11 Ikon

Ikon

    Harbinger of the Balance

  • Istrum
  • PipPipPipPipPipPip
  • 2788 posts

Posted 10 December 2014 - 16:29

Running down from Nela's kart towards the stairs that leads to the water front, you can have Zoe scale the building by sticking to the wall on the small ramp as you go around.

You can then drop back behind the scenery again and go running around.


Seems like all the music has been restored. All of it seems to work for me.

 

That's a good one. Things like this are exactly the kind of glitch I envisioned being discovered by fan Beta testers :)


If at first you don't succeed, do it like your mother told you.


#12 Morten

Morten

    RTG Programmer

  • RTG Staff
  • 1061 posts
  • LocationOslo, Norway

Posted 10 December 2014 - 17:45

And I notice a nasty problem with this patch (both in 4k and 1080), when I press esc (for the menu) and press esc again it somehow hangs the game and doesn't resume , I have to end the process. The particular problem is that the menu is about to go away on pressing esc the second time, but the game gets stuck and whatever post processing is used to darken and desaturate the screen when in pause doesn't dissapears but hangs.

Yes, I can confirm this. And I can also confirm that this is a new issue with the latest beta build (aka. it doesn't happen in the previous one).

It most likely has nothing to do with the desaturation effect being tweened out, but rather something else going wrong when going back to normal game time. 

I'm currently looking into it and I can definitely say that 1.1.3 will not be officially released until its cause is found and the issue is resolved.


  • agirlnamedbob, khh, CosmicD and 1 other like this

Red Thread Games PR0grammer & Naturally Selected Part-Time "Keep Track of Forum"-person / Community Overseer


#13 Ikon

Ikon

    Harbinger of the Balance

  • Istrum
  • PipPipPipPipPipPip
  • 2788 posts

Posted 10 December 2014 - 21:02

Nice work guys; this is Beta testing doing its thing :)


If at first you don't succeed, do it like your mother told you.


#14 Lee-m

Lee-m

    Harbinger of the Balance

  • Vestrum
  • PipPipPipPipPipPip
  • 1869 posts
  • LocationYorkshire, England

Posted 10 December 2014 - 21:41

Nice work guys; this is Beta testing doing its thing :)

I would be easier if we had more information. For example, we are told v-sync caused issues and is now being included in the beta. But we are not told were these issues showed up in the game or what they were. So its pretty much impossible to know what bug could be attributed to what feature. I could have posted a bunch more, but I have no idea if they have anything to do with this beta versions features or not.

#15 CosmicD

CosmicD

    Vestrum Herald

  • Shifter
  • PipPipPipPipPip
  • 1555 posts
  • LocationHasselt, Limburg, Belgium

Posted 10 December 2014 - 23:27

I thought it had a problem with the animations, (i guess it would interpolate weirdly and could look stutter "ish" ? Didn't really see anything in that sense though.



#16 Ikon

Ikon

    Harbinger of the Balance

  • Istrum
  • PipPipPipPipPipPip
  • 2788 posts

Posted 10 December 2014 - 23:40

Well guys, that would be part of the process. Post your findings here and then others can test the findings and confirm them or not.


If at first you don't succeed, do it like your mother told you.


#17 Lee-m

Lee-m

    Harbinger of the Balance

  • Vestrum
  • PipPipPipPipPipPip
  • 1869 posts
  • LocationYorkshire, England

Posted 11 December 2014 - 03:01

Well guys, that would be part of the process. Post your findings here and then others can test the findings and confirm them or not.

It was pretty clear we should only post stuff relevant to the beta, any stuff affecting the main game should be posted in the usual fashion. The bug I posted about scaling the walls might very well apply to previous versions, or it it could be a symptom of the new v-sync. Its hard to know if I should be posting that stuff here or not. I have a bunch of others I just havent posted.

Would be nice to have a list of known problems with features in beta releases. Not just a list of new features.

#18 Olstyle

Olstyle

    Vestrum Crier

  • Istrum
  • PipPipPipPip
  • 597 posts
  • LocationGermany

Posted 11 December 2014 - 09:15

Why don't you just post what you got so Morten can answer with either "we know this" or "this is new to us".
I know it's not perfect, but it sounds like a feasible alternative to me.

#19 Morten

Morten

    RTG Programmer

  • RTG Staff
  • 1061 posts
  • LocationOslo, Norway

Posted 11 December 2014 - 15:00

It's not the biggest deal in the world if the problem has been mentioned before or found by someone in the officially released version. 

It's just a guideline that helps us seperate the two branches and what issues are specific to the beta/official build.

 

Don't be afraid to post what issues you've found here, but it's of course no use of posting things like "Lens Flares still look buggy" or "My joypad is still not working for me, and haven't since launch", basically things that are well known to be issues in the main branch ;).

 

Stuff like the wall-climbing glitch is possible in the main branch too, but it hasn't really been mentioned or found before testing the beta, so that's more like one of those edge cases I think. 

Anyhow, it's better that you mention an issue (like the wall-climbing one mentioned) that you are unsure about than not mentioning it at all. :)


  • Edreamer Jamil, agirlnamedbob, Lee-m and 2 others like this

Red Thread Games PR0grammer & Naturally Selected Part-Time "Keep Track of Forum"-person / Community Overseer


#20 CosmicD

CosmicD

    Vestrum Herald

  • Shifter
  • PipPipPipPipPip
  • 1555 posts
  • LocationHasselt, Limburg, Belgium

Posted 11 December 2014 - 17:43

I've neglected to tell what settings i'm using, basicly everything on max (graphics, sseao, anti aliassing, 4k, bloom and flares enabled) shadow distance: 6m, vsync on , no grain, no motion blur.







Also tagged with one or more of these keywords: Beta v1.1.3

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users