Jump to content


Photo
- - - - -

Just 10 FPS ???

Framerate

Best Answer Morten , 28 November 2014 - 13:56

Just a thought, PeterPan1973:

You wouldn't happen to have the Power Saving option turned on in Windows, would you?

That would limit all applications in terms of how much resources they can take advantage of to, of course, save power consumption.

 

You can find out by going to Control Panel -> Power Options, make sure the "Power Saver"-option is not checked, and that you're either running on "Balanced" or "High Performance". 

If "Balanced" is the one enabled, try using "High Performance", found by clicking the "Show additional plans" button below the "Power Saver"-option, to see if this resolves the issue.

Go to the full post


  • Please log in to reply
45 replies to this topic

#41 Olstyle

Olstyle

    Vestrum Crier

  • Istrum
  • PipPipPipPip
  • 597 posts
  • LocationGermany

Posted 01 December 2014 - 18:33

I very much doubt that. Afaik you would need admin-privileges to do so, which games don't get normally. Could you name one?

#42 Grul

Grul

    Rubber Ducky

  • Member
  • Pip
  • 2 posts

Posted 01 December 2014 - 22:44

I did get a pretty lousy experience as well, until I turned down the shadow distance. The shadow distance should REALLY not be as high as it is; I went from like 10 FPS to 30 by dialing it back to zero. Changing all the other stuff like resolution or motion blur didn't do much of a difference (possibly with the exception of texture quality). I think you will give your players a much better experience overall by defaulting the shadow distance to zero.

 

I'm on a AMD Radeon HD 5700 Series, quad-core AMD processor, 8 gigs of ram, no overclocking or custom settings. Just defaults. The power saving setting was Balanced but switching to performance didn't seem to make a difference.



#43 Grul

Grul

    Rubber Ducky

  • Member
  • Pip
  • 2 posts

Posted 01 December 2014 - 22:51

Furthermore, you can update the FAQ and advise people on what to try to turn down first. Just "try lowering settings" isn't very specific. Like I said, in my case it was overwhelmingly shadow distance that had an effect, and secondarily quality. The game was never close to maxing out the CPU.



#44 Ikon

Ikon

    Harbinger of the Balance

  • Istrum
  • PipPipPipPipPipPip
  • 2788 posts

Posted 01 December 2014 - 22:52

Furthermore, you can update the FAQ and advise people on what to try to turn down first. Just "try lowering settings" isn't very specific. Like I said, in my case it was overwhelmingly shadow distance that had an effect, and secondarily quality. The game was never close to maxing out the CPU.

 

Good idea.


If at first you don't succeed, do it like your mother told you.


#45 khh

khh

    Harbinger of the Balance

  • Moderator
  • 7119 posts
  • LocationNorway

Posted 01 December 2014 - 22:53

Furthermore, you can update the FAQ and advise people on what to try to turn down first. Just "try lowering settings" isn't very specific. Like I said, in my case it was overwhelmingly shadow distance that had an effect, and secondarily quality. The game was never close to maxing out the CPU.

The CPU load is largely isolated to a single thread, so on a multi-core system you'll never see it reach 100 % in task manager. So by itself that doesn't mean that performance isn't CPU bound.

 

edit: From what I've read lowering shadows to 0 can cause visual artefacts that are much more significant than those you get with lowering other settings, so I hesitate to say so in the FAQ.


  • Morten and Mr Moo like this

April Ryan is my friend,
Every sorrow she can mend.
When I visit her dark realm,
Does it simply overwhelm.


#46 Morten

Morten

    RTG Programmer

  • RTG Staff
  • 1061 posts
  • LocationOslo, Norway

Posted 02 December 2014 - 10:57

khh is correct.

Lowering Shadow Distance to 0 meters makes the game look really horrible. Actually we would like to change that to be a minimum of 5 meters.

That said, I'm sure you understand that we don't want to default to 0m for Shadow Distance. :)

Currently, the game is defaulted to Medium quality, which in turn places the Shadow Distance setting on 8 meters. Changing Visual Quality in-game you'll see that the Shadow Distance value as well as DoF is changed for certain levels. :)

 

But really, the shadows shouldn't have such an impact on how the game performs on your computer unless you have a pretty old GPU, which I guess you don't have since you are mentioning this as a problem(?).

 

"Try lowering settings" is really a general term here. Different people have vastly different systems. For some, their CPU might be the bottleneck. For others, maybe the GPU or available system memory is the culprit. All of which are impacted by different settings (i.e. Post Processing effects are generally hogging the GPU, Texture/Visual Quality is more of a RAM thing, etc.). So, it would mean a lot of work to put together a Q/A for every different scenario. 

 

We are trying to update the FAQ when new issues arrive, or issues that will have to be explained in a more specific way. :)

 

Hmm, we could actually update with something along the lines of what I just wrote above. That would be a bit more specific. Hey, I guess you just made me do it after all..  :P


  • khh, Riaise, Mr_Russ and 1 other like this

Red Thread Games PR0grammer & Naturally Selected Part-Time "Keep Track of Forum"-person / Community Overseer






Also tagged with one or more of these keywords: Framerate

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users