Jump to content


Photo
- - - - -

Just 10 FPS ???

Framerate

Best Answer Morten , 28 November 2014 - 13:56

Just a thought, PeterPan1973:

You wouldn't happen to have the Power Saving option turned on in Windows, would you?

That would limit all applications in terms of how much resources they can take advantage of to, of course, save power consumption.

 

You can find out by going to Control Panel -> Power Options, make sure the "Power Saver"-option is not checked, and that you're either running on "Balanced" or "High Performance". 

If "Balanced" is the one enabled, try using "High Performance", found by clicking the "Show additional plans" button below the "Power Saver"-option, to see if this resolves the issue.

Go to the full post


  • Please log in to reply
45 replies to this topic

#1 PeterPan1973

PeterPan1973

    Rubber Ducky

  • Member
  • Pip
  • 10 posts

Posted 28 November 2014 - 12:05

Hi,

i really dont understand, why i only habe 10 frames/second.
I have an intel core i5, 16 GB Ram, Geforce GTX 970!!

It even gets worser, when i got to my appartement. This is not a big level!!! I really dont understand!!

My System is 64 Bit Windows 8.1.

In Taskmanager the Dreamfall.exe shows (32bit) ???????? Is that normal?

I Bought Dramfall Chapters via Steam....

Can anyone help me??????

I would love to play this game, but with 10 FPS ist is really unplayable!!! The Stuttering is awful!!

:-((((((



#2 PeterPan1973

PeterPan1973

    Rubber Ducky

  • Member
  • Pip
  • 10 posts

Posted 28 November 2014 - 12:18

Maybe its important: My CPU Usage is 12% only. I really dont understand anything :-(



#3 urzagc13

urzagc13

    Vestrum Herald

  • Drachkin
  • PipPipPipPipPip
  • 1052 posts
  • LocationGreece

Posted 28 November 2014 - 12:26

Others, more technical-minded (including the programmers from Red Thread Games themselves) will be able to respond to you about the issues you're having. I noticed though that you didn't mention what graphical settings you're running the game on. Does this very bad performance remain when you lower the graphical quality? And have you got the latest drivers for your graphic card?

 

Finally, I'd like to let you know that there's a performance patch coming today that could potentially address your problem.


Giorgos Chrysikopoulos - Dream Traveller

 

Check out the unofficial (headcanon) backstory of my Europolis Most Wanted Dreamfall Character: meet the "The Scientist Thief"!

 


#4 Morten

Morten

    RTG Programmer

  • RTG Staff
  • 1059 posts
  • LocationOslo, Norway

Posted 28 November 2014 - 12:54

We have many machines at our office with almost equal specs as you, PeterPan1973. We're at ~30 fps in Europolis, ~60 fps in Storytime, ~30 fps in Friar's Keep (I don't know where you're at in the game so just listed some scenes for reference).

12% CPU usage seems very low, at least if you're in Europolis, which is the heaviest scene of the game. I'm personally running the game with 40%-50% CPU usage.

Rendering in Unity is CPU-bound, so you should see a higher CPU usage than 12% at least.

 

With regards to the executable being 32-bit; this is because there's a bug in Unity where random crashes occurs on 64-bit standalone builds. This bug is fixed with the latest patch of Unity, which we've tried implementing.

However, this patch unfortunately introduced other bugs, which means we could not apply it to the game. Until it is fixed properly, we have to build 32-bit executables only.

 

Are you sure you're not running some third party tools taking control of other applications? Are you overriding graphics settings from your Nvidia Control Panel?

What other programs are you running alongside the game? Anything that uses a lot of CPU, which in turn decreases the available CPU processing for the game?

Any settings limiting usage of CPU or multiple cores?

You'd also might want to try to reconfigure some of the in-game settings to see if enabling/disabling any of them makes the experience better. However, with almost equal hardware, I'm more than able to run the game with the best settings possible.

 

Sorry I can't help you with anything more than this at the moment. It does seem like an odd issue, one that we haven't seen ourselves. Anyone else having/have had this issue?

I'll make sure to update you if we find anything that might help with your problems.


  • khh and Em_TC like this

Red Thread Games PR0grammer & Naturally Selected Part-Time "Keep Track of Forum"-person / Community Overseer


#5 Lee-m

Lee-m

    Harbinger of the Balance

  • Vestrum
  • PipPipPipPipPipPip
  • 1859 posts
  • LocationYorkshire, England

Posted 28 November 2014 - 12:57

I play the game just fine on a very similar set up to yours, except I have a 980gtx, so you should be seeing good performance. The game tends to pull around 50-60fps all over europolis, so I suspect something is going on with your system.

First thing to check is you have the latest nvidia drivers, thats important (currently 344.75). Maybe try disabling your anti virus and see if that helps any.

You dont say what version of the game your running (where you bought it from).

Edit: Sorry im clearly blind.

 

All versions (aside from maybe the linux one) are 32bit, so thats normal.



#6 khh

khh

    Harbinger of the Balance

  • Moderator
  • 7118 posts
  • LocationNorway

Posted 28 November 2014 - 13:00

You dont say what version of the game your running (where you bought it from).

He mentions he got it from Steam, so he's got the latest updates.

 

I think the most likely culprit is either settings in the Nvidia control panel (force vsync, for AA, force AF, force tesselation) or the game being limited to run on one core.


April Ryan is my friend,
Every sorrow she can mend.
When I visit her dark realm,
Does it simply overwhelm.


#7 Lee-m

Lee-m

    Harbinger of the Balance

  • Vestrum
  • PipPipPipPipPipPip
  • 1859 posts
  • LocationYorkshire, England

Posted 28 November 2014 - 13:10

or the game being limited to run on one core.

purely in the interests of science, I ran europolis on one core, and it still pulls 20fps, and its perfectly playable. The sound cuts out abit but thats it.



#8 Dmm

Dmm

    Vestrum Crier

  • Drachkin
  • PipPipPipPip
  • 754 posts

Posted 28 November 2014 - 13:19

In my case I disabled shadow distance and my frame rate went from 10-20 fps to 30 to 45 fps. I also disabled AA. You might try that. I have a older machine with a quad core multi-thread i7 950, AMD Radeon 6850 SLI, Win 7 Home Premium. My monitor is 2560x1600.



#9 PeterPan1973

PeterPan1973

    Rubber Ducky

  • Member
  • Pip
  • 10 posts

Posted 28 November 2014 - 13:24

first of all, thank you for your answers, an trying to help me....

I use the latest Drivers.
When i put the Settings in the game to minimal, it changes nothing.
I have no others programms running.
And i have nothing changed to the graphics cards settings.
Its just as i bought it... i know nvidia control panel, but dont use it. Im not so technically good at these things ;-)

I wonder, why my CPU usage is just 12% in Europolis. There is definitly something wrong with my system, but i dont know what....
I hope, that the patch will help me, this would be great!!

How can i check, if its working on just one core??
 



#10 khh

khh

    Harbinger of the Balance

  • Moderator
  • 7118 posts
  • LocationNorway

Posted 28 November 2014 - 13:25

purely in the interests of science, I ran europolis on one core, and it still pulls 20fps, and its perfectly playable. The sound cuts out abit but thats it.

That's really interesting actually. Thanks :)

(My CPU is too old for such a test).

 

edit:
PeterPan1973 it seems like it running on one core is probably not the cause of your problem. And it would not do so unless you'd told it to, which I guessing you haven't.


April Ryan is my friend,
Every sorrow she can mend.
When I visit her dark realm,
Does it simply overwhelm.


#11 PeterPan1973

PeterPan1973

    Rubber Ducky

  • Member
  • Pip
  • 10 posts

Posted 28 November 2014 - 13:27

I turned down the shadows complete, no Anti Aliasing, turned down the resolution, etc etc.
And what i really dont understand... europolis, ok. Its a big level. But when i enter my Appartement in Sunshine Plaza.... there goes nearly nothing!!!
 



#12 Lee-m

Lee-m

    Harbinger of the Balance

  • Vestrum
  • PipPipPipPipPipPip
  • 1859 posts
  • LocationYorkshire, England

Posted 28 November 2014 - 13:32

I turned down the shadows complete, no Anti Aliasing, turned down the resolution, etc etc.
And what i really dont understand... europolis, ok. Its a big level. But when i enter my Appartement in Sunshine Plaza.... there goes nearly nothing!!!
 

Your hardware should run the game perfectly on max settings, so the issue must be some where else. Did you make sure you have the latest nvidia drivers ?
Other than that, I would suspect some software you have running.



#13 Morten

Morten

    RTG Programmer

  • RTG Staff
  • 1059 posts
  • LocationOslo, Norway

Posted 28 November 2014 - 13:56   Best Answer

Just a thought, PeterPan1973:

You wouldn't happen to have the Power Saving option turned on in Windows, would you?

That would limit all applications in terms of how much resources they can take advantage of to, of course, save power consumption.

 

You can find out by going to Control Panel -> Power Options, make sure the "Power Saver"-option is not checked, and that you're either running on "Balanced" or "High Performance". 

If "Balanced" is the one enabled, try using "High Performance", found by clicking the "Show additional plans" button below the "Power Saver"-option, to see if this resolves the issue.


Red Thread Games PR0grammer & Naturally Selected Part-Time "Keep Track of Forum"-person / Community Overseer


#14 PeterPan1973

PeterPan1973

    Rubber Ducky

  • Member
  • Pip
  • 10 posts

Posted 28 November 2014 - 14:10

ok, this would be an idea. Right now i´m in the office and cant try....
But i let you know, if it worked...

Though i think its not the case, because all other games run very smoothely. Even with Ultra settings....

But i will give it a try!! ;-)


  • Morten likes this

#15 Morten

Morten

    RTG Programmer

  • RTG Staff
  • 1059 posts
  • LocationOslo, Norway

Posted 28 November 2014 - 14:15

Great!

I wouldn't think that would be the case either, unless you've set this to Power Saver specifically at some point in time. Worth a shot, though ;)

 

I'll update if I come up with anything else.


Red Thread Games PR0grammer & Naturally Selected Part-Time "Keep Track of Forum"-person / Community Overseer


#16 PeterPan1973

PeterPan1973

    Rubber Ducky

  • Member
  • Pip
  • 10 posts

Posted 28 November 2014 - 14:28

OK, thank you :-)

 



#17 Riaise

Riaise

    Vestrum Crier

  • Minstrum
  • PipPipPipPip
  • 664 posts
  • LocationEngland

Posted 28 November 2014 - 16:27

I'd just like to say that I think I'm having the same problem. I don't play games with this type of graphics, so to me DFC looks amazing, but after reading this post I just checked my frame rate and I'm only getting about 10 fps in Europolis, too. Even if I use all of the lowest settings and turn off shadows and anti-aliasing, it only goes up to around 14 fps at the most. So I checked Task Manager while the game was running and it was only using about 15% CPU. Nothing else that was running (Windows processes and things) was using more than 1%.
 
I have an AMD A8-5500 APU with 6 GB RAM, and AMD Radeon HD 7560D on Windows 8.1 64 bit. I'm using the GOG version of Chapters with the 1.1.1 patch.
 
Again, it doesn't bother me personally, but I thought I would mention it in case it helps with finding the problem. :)


#18 Lee-m

Lee-m

    Harbinger of the Balance

  • Vestrum
  • PipPipPipPipPipPip
  • 1859 posts
  • LocationYorkshire, England

Posted 28 November 2014 - 16:41

I have an AMD A8-5500 APU with 6 GB RAM, and AMD Radeon HD 7560D on Windows 8.1 64 bit. I'm using the GOG version of Chapters with the 1.1.1 patch.

 

Just as a quick response, the A8 5500 is a weak gaming cpu, its really aimed more at bing a media box etc.. so its no surprise that you would experience low fps in places. The OP has an i5 (great gaming cpu) and a top gfx card, his hardware should be getting him 50fps at least.



#19 migatora

migatora

    Rubber Ducky

  • Istrum
  • Pip
  • 11 posts

Posted 28 November 2014 - 19:34

Hi,

 

I had a similar problem and looked at the Nvidia control panel where, surprisingly, DFC was set to use the integrated Intel GPU as default. Since this is an option that can be modified, I set it so the game will use the discrete GPU (GT 750M, by the way). The improvement was immediate and I have not had other issues since. 

 

Also, as others pointed out, I used to choose the "High performance" power plan before playing, so the CPU is used at its fullest. DFC use a lot the CPU for rendering, it seems. But not anymore, using this trick: since I always play games in my laptop when it is plugged-in, I created a custom power plan, that when on battery, it behaves as the "power saving" plan and when plugged-in, it behaves as the "High performance" plan. That way I do not have to switch manually every time.

 

Cheers,

 

Miguel


  • Mr Moo likes this

#20 PeterPan1973

PeterPan1973

    Rubber Ducky

  • Member
  • Pip
  • 10 posts

Posted 29 November 2014 - 16:00

OH MY GOD!!!!!!!!!!! ITS RUNNING!!!!! I am soooo happy!!! Thank you guys at redthreadgames!! You did really some good work!!!! Thank you so much!!!!

 

:-)


  • Tina and khh like this





Also tagged with one or more of these keywords: Framerate

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users